Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Office 2007 on Windows XP-SP3. My mouse wheel works fine in other applications, meaning that it scrolls information up and down when the mouse is positioned over a given panel. It's even working fine in the other Office 2007 apps, so this is not a hardware or driver problem.

It doesn't help to click on a cell to give the worksheet focus.

I've tried various Advanced options that people recommend, to no avail:

  • Allow editing directly in cell
  • Zoom on roll with IntelliMouse

What the heck, has Microsoft disabled this most useful functionality?

share|improve this question

10 Answers 10

up vote 2 down vote accepted

The formula bar in Excel 2007 has become a multiline field and Microsoft has opted to allow the scroll wheel to scroll through the formula bar instead of through the spreadsheet.

One way to fix this is to turn off Universal Scrolling for the Excel application. Follow the instructions below to turn off Universal Scrolling for Excel:

  1. Click on your Start button.

  2. Click on Control Panel.

  3. Double-click your Mouse icon.

  4. Click on the Wheel tab at the top.

  5. Click on the Exceptions button.

  6. Click on the Add button

  7. Under Application Name, type Excel.

  8. Click on the Browse button and locate the Excel application on your machine. For Excel 2007, this is typically:

    C:\Program Files\Microsoft Office\Office12\Excel.EXE
    
  9. Double-click on the Excel application executable or highlight it and click the Open button.

  10. Click OK all the way out.

  11. Reopen Excel and test the changes.

share|improve this answer

1) I went to Start, Control Panel, Mouse, Wheel and clicked on "Office 97 Emulation".

2) Open an Excel file / Click on "Office Button" located on the top left corner / Click on

"Excel options" button / Choose "Advanced" / Look for "Zoom on roll with IntelliMouse"

then uncheck that option / Click "OK"

share|improve this answer

Press Alt + W then F on the last visible row on the screen; this will unlock the pane and the scrolling should hopefully work as you expect again.

share|improve this answer

I had a similar problem and it was none of the above. Check to make sure you did not accidentally freeze panes in some place outside of your viewable data. Click on view/window/freeze panes/unfreeze panes

share|improve this answer

Same issue - not able to use scroll wheel to navigate up / down within Excel (2010, with XP SP3). My fix was File / Options / Advanced - click on "Zoom on roll with Intellimouse", Okay. Zoom about a bit for good fun. Then de-select zoom and all is well for me.

share|improve this answer

I had no vertical scroll in Excel 2010 and IE 8 (using Office 2010, Windows XP-SP3 and a wired Logitech optical mouse), but it worked OK in Outlook, Word, etc. I tried to toggle on/off the zoom option in Excel (and the zoom worked) but scrolling didn't return. I also tried many of the other solutions out there that I could, but my options on the Control Panel, 'Mouse' applet's 'Wheel' tab were very limited.

Finally, I decided to download and install the most recent version of Microsoft's IntelliPoint software (v8.2, basic optical version for USB & PS/2), even though I was using a Logitech mouse:

 http://www.microsoft.com/hardware/en-us/d/basic-optical-mouse

Other options can be found here:

 http://www.microsoft.com/hardware/en-us/downloads

I figured that since my Logitech mouse didn't need any special software to run (according to Logitech), that updating this software might help. I could always uninstall it later if it didn't help. After installing the software and rebooting, my problems have been solved.

The Control Panel applet correctly says it can't detect a Microsoft mouse, but it added various vertical scroll options to the 'Wheel' menu and everything works great for me now (with default options selected). I don't need to reassign button functions, etc. so that is no loss, I'd much rather have a functioning vertical scroll. If full functions are important to you, Microsoft recommends downloading/installing a version prior to Intellipoint v8.0.

I hope this helps!

share|improve this answer

I had a similar problem with the IntelliMouse not scrolling in Excel 2010. It worked fine in all other Microsoft Office applications. I went to Start, Control Panel, Mouse, Wheel and clicked on "Office 97 Emulation" and that fixed it. I had tried entering an exception first, but that did not work.

share|improve this answer

The IntelliPoint driver has something called Universal Scrolling. To get the mouse wheel to work for Excel 2007, open the Mouse Control Panel, go to the Wheel tab, and select "Office 97 Emulation". There is also an Exceptions list to which other executable paths can be added for similar treatment. Internet Explorer is in this list by default.

Here is a KB article on Universal Scrolling: http://support.microsoft.com/kb/821487

share|improve this answer

I had the same problem - Excel (Office Standard 2010 + Win 7 Pro) suddenly stopped vertical scrolling.

In Options / Mouse / Wheel, there was a link to "Identify programs that don't scroll correctly". I added Excel and it started scrolling again.

share|improve this answer

As previously stated: The formula bar in Excel 2007 has become a multiline field and Microsoft has opted to allow the scroll wheel to scroll through the formula bar instead of through the spreadsheet.

So, when you have this problem, make sure you click out of the formula bar, back into the excel spreadsheet (by clicking on any cell in the spreadsheet), and you will be able to scroll again.

share|improve this answer
    
Welcome to Superuser. The OP has already stated that clicking on a cell to give the worksheet focus does not work and quoting someone else's answer brings nothing new to the OP. May I suggest you take the tour and see what this site is and isn't about? superuser.com/about –  Tog Oct 2 '13 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.