Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every once in a while (5 minutes or so), gedit interrupts my typing with a little "This file has changed on disk" message and asks me if I'd like to reload it.

I know that the file isn't being changed.

  • It's located on a local disk
  • only I am editing it
  • if I click "reload" on the dialog, there is no visible change in the file

This doesn't happen in other text editors like Emacs or EditPlus.

Does anyone know what the problem is and/or how to fix it?

share|improve this question
    
And before anyone says it, yes I guess the solution potentially is "Just keep using Emacs", but I want to know if there is a way to fix this gedit problem on my windows machine. –  Inaimathi Dec 4 '09 at 15:48
    
Try using a tool like FileMon and see what happens when you get that message. Maybe some app indeed tries to change it. –  geek Dec 4 '09 at 16:03
    
Tried it. FileMon showed lots of activity, but the only writes on the target file seemed to be coming from Gedit (BitDefender was doing reads, so I'm tempted to write this off as the effect of over-zealous virus software, but that's the best I could think of). –  Inaimathi Dec 5 '09 at 16:40

3 Answers 3

up vote 1 down vote accepted

Have a look at jEdit, I know, not the solution to your problem, but I found it quiet a good replacement for GEdit (at least on Windows).

share|improve this answer

Is the file on a remote disk? In Linux I get that problem sometimes when I'm editing a file on a network drive... so I just make a local copy, edit it, save, and copy back to the file server.

What file system format is the file on? NTFS or FAT?

share|improve this answer
    
It is a local file; I'll amend the question to make that clearer. The disk is NTFS format. –  Inaimathi Dec 4 '09 at 15:56

I had a similar problem recently while working in Delphi. I'd get messages asking me to re-load my source files and it was because of Symantec constantly scanning every little file that changed, no matter what the change was. Adding an exclusion for my source folders solved it though. Might be something similar for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.