Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Ubuntu, When trying to open Firefox it is saying that it is already running but not responding. I am on a system where I dont have access to view the root. I have had this issue before and fixed it but I dont remember how. I know before I had to delete a file but I dont remember what or where.

share|improve this question

4 Answers 4

up vote 6 down vote accepted

It's probably that your profile is locked; happens on unclean shutdown sometimes.

See this support page on Mozilla.com, specifically:

  • pkill firefox (or restart your computer). Don't try to start Firefox.
  • Go to your Firefox profile folder - see How to find your profile.
  • Delete the lock file parent.lock

Your profile is in ~/.mozilla/firefox/*.default/ (the * will be a random sequence of 8 letters)

rm parent.lock and try again.

share|improve this answer

Open terminal window. type:

sudo killall firefox

Try to open firefox again

share|improve this answer
    
that didnt work –  Josh Curren Dec 4 '09 at 18:11
    
What output do you get when you use this command: ps aux | grep firefox ? –  ricbax Dec 4 '09 at 18:13
    
cs20566 13560 0.0 0.0 7524 900 pts/0 R+ 13:15 0:00 grep firefox –  Josh Curren Dec 4 '09 at 18:16

This post could be the solution @ http://ubuntuforums.org/archive/index.php/t-493848.html

If you need to kill firefox, you can try going under System->Adminstration->System Monitor and select the processes tab. Look for firefox and right click on it. It should give you an option to kill the process. If that does not work, you might try going into the Terminal and type:
ps -ef|grep firefox

If firefox is running, it should show up as a process and have a number attached to it. It will be the first number after the username. For example:

jayhawk@jayhawk:/$ ps -ef|grep firefox
jayhawk 8137 26283 0 14:21 pts/0 00:00:00 grep firefox
jayhawk 24213 1 0 07:22 ? 00:00:00 /bin/sh /usr/bin/firefox-granparadiso

In this scenario, the process number is 24213 for firefox (I am running the alpha version of firefox so your firefox name will be different). Just type:
kill 24213

Then check again by using the ps -ef grep firefox command. If it is still there, you can use:
sudo kill -9 24213

And that should kill it.

share|improve this answer

Yes, or simply open your terminal and...

1) go to firefox directory by typing:   cd .mozilla/firefox
2) type: ls  (..now you should see file profiles.ini)
3) remove profiles.ini file by typing:  rm profiles.ini

that's it, start Firefox again :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.