Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally on my Vista laptop I will be greeted with a password prompt. However it will not accept my password as valid (I've done this enough times to know that it's not a case of me forgetting my password).

If I click the "switch user" button, then I can login as normal and all my processes and windows are still running just as I left them.

Any ideas?

share|improve this question
add comment

5 Answers 5

This might be a problem with using a buggy screensaver, if it's not one of the standard ones that come with Windows.

Try to change the screensaver and see if the problem persists.
If it still happens, try to turn it off (define the screensaver as None).

share|improve this answer
add comment

I had this problem as well, I was running Vista ultimate on a HP laptop. I couldnt figure it out either, so I just upgraded to windows 7 Pro. Now I have no more issues

share|improve this answer
    
Thanks - so that makes two things we have in common (my laptop is a HP Pavilion dv2000) - however I'm running Vista Home Premium (32 Bit) - an upgrade to Win Pro 7 will be a tad more painful for me than it was for you.... –  user20232 Dec 4 '09 at 19:34
    
I just wiped it clean, no need to upgrade. I would recommend the same. Vista sucks –  Mike K Dec 4 '09 at 20:34
add comment

Check default language at the lower corner.

share|improve this answer
    
Thanks - next time I witness the problem I will make sure it's set appropriately. –  user20232 Dec 4 '09 at 20:34
    
Keep us posted! –  Saxtus Dec 4 '09 at 23:07
    
Well it took a long time for it to happen again... sadly there was no language option. –  user20232 Dec 11 '09 at 23:50
add comment

Assuming you are getting the logon prompt while running, then it may be the screen saver password option is set. Right click the desktop, go to properties, go to screen saver and uncheck On resume display logon prompt.

If this is your problem, then I'd try and go into Start-Control Panel-User Accounts and Family Safety-Change Your Windows password. Try and change it, shut down completely, come back up and reset the screen saver to require password, change to only a minute or so and test.

share|improve this answer
add comment

It could be two things:

1) Keyboard language issue:

Compare the two account:

  1. Click Start and then Control Panel
  2. In Control Panel, if you are in Classic View, click on Control Panel Home (top left corner)
  3. Open Clock, Language, and Region
  4. Click on Regional and Language Options.
  5. Check the Keyboards and Languages tab

    And use the settings of the working account on the other one

  6. Check also your administrative tab. And If your are sure of your settings you could use the "Copy to reserved accounts" under "Reserved accounts"

2) State of F-Lock/Numlock keys issue:

Try to change their states before entering your password

If it works, they are some registry keys to change it permanently

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.