Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem (or at least seems strange to me) the below are IP configurations for two laptops on my home network which consists of a main router 192.168.11.1 and a connected wireless router (i know this can cause problems but has always worked until I got the win7 machine) at 192.168.11.2 with DHCP disabled.

Laptop 1 - Win XP IP: Dynamically assigned by main router default gateway: 192.168.11.1 (main router)

This machine gets perfect connectivity.

Laptop 2 - Win7 IP: dynamically assigned by main router Default Gateway: 192.168.11.2 THIS IS THE PROBLEM... I cannot seem to get this machine to default to the main router for the gateway UNLESS I go to a static configuration which I would rather not do since I regularly go between my home and public networks.

Why is my Win7 machine not finding the main gateway the same way that the other laptop is?

I believe that the rest of my setup is fine as it has always worked and it works perfectly when set as static ip and gateway.

Please help!

Thanks

share|improve this question
    
did you install any 3rd party connection manager with the network controller driver? and please post make and model. –  Molly7244 Dec 4 '09 at 23:53
    
What IP and mask is laptop 2 getting? And are you UTTERLY CERTAIN that DHCP is disabled on 192.168.11.2? And can you give us the pool that 192.168.11.1 is handing out? –  goblinbox Feb 10 '12 at 19:47

5 Answers 5

To disable IPV6 you must do so by registry or GPO. In you uncheck you only unbind from NIC, but OS still uses on network. On 7 and 2008 disabling IPV6 not recommended.

share|improve this answer
    
How can you do it in the registry? –  Simon Sheehan Nov 8 '11 at 20:47

Are the main router and the wireless router both configured to be DHCP servers? If so, that could be the problem. Disable the DHCP server on one or the other of them.

share|improve this answer
    
DHCP is disabled on the WAP. Whats strange is that one laptop finds the correct gateway on its own.... yet the other has to be set static to do so. –  Matt Dec 4 '09 at 22:43

On the Windows 7 machine open a command prompt and run ipconfig /all and post the results here (you can omit the Physical Address if you want, some people are paranoid about it). You can copy the text from the command prompt by right clicking and selecting Mark, selecting the region you want to copy and then right clicking on the selected text.

This will show us the full configuration of your adapter plus which IP is acting as your DHCP server.

share|improve this answer

You also might want to clear you ARP table on the windows 7 machine. Run a command prompt in administrative mode and type

arp -d *

Also, you may want to disable IPv6. I ran into a small problem with IPv6 + Vista + Linksys wireless routers. To disable IPv6, go to Start->Run, Type "ncpa.cpl". Right click on the connection and go to properties. You should see a box for "Internet Protocol Version 6", uncheck it and click OK.

share|improve this answer

I was getting two Default Gateways, but in my home network there was just one. I've tried many things, but what worked was disabling and re-enabling my adapter.

To do that, go to Network & Sharing > Change adapter settings > Right click on your adapter > Disable > Right click again > Enable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.