Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I use an XP box via VNC, everything works fine except for Openoffice which is very slow.

Why is that, is there a way to fix it?

PS: The WinXP box works fine when I use it without VNC including OOO.

share|improve this question

migrated from serverfault.com Dec 4 '09 at 21:00

This question came from our site for professional system and network administrators.

    
Is this connection over an internal network or the internet? –  Troggy Dec 4 '09 at 21:04
    
Which version of VNC are you using? RealVNC, TinyVNC, UltraVNC? –  stukelly Dec 11 '09 at 0:34

3 Answers 3

For the source of the problem, it may relate to how OpenOffice is drawing the screen to attempt to make things look like they do on paper.

For a possible solution, which VNC are you using? UltraVNC (uvnc.com) and possibly others have some modules that I believe tie in with the graphics to improve performance.

share|improve this answer

As fencepost mentioned, UltraVNC has a optional video hook driver, which can improve performance.

If your using UltraVNC, to improve speed, right click on the UltraVNC icon on the taskbar and select properties. Then tick the following boxes:

  • Poll Full Screen
  • Poll Foreground Window
  • Poll Window Under Cursor
  • System HookDll

Properties

If you are using the video hook driver, check if the Video Hook Driver option is ticked.
Then press OK to save the new settings.

share|improve this answer

The problem sounds like the frequent redrawing of the OpenOffice window. Since OpenOffice's layout has a lot of components (and uses a fair bit of memory), every time you type a letter the screen has to be redrawn over the connection to update the image so you can see what you've typed. You can improve things by turning on a feature called bitmap caching, although I'm not sure if VNC has this. What it essentially does is save parts of the remote screen to the local computer, so every time something must be redrawn, it can just do a small area instead of the whole screen:

alt text

I know the Windows RDP client has this option so check out VNC's advanced settings, turning off menu and window animations will also help.

share|improve this answer
    
Showing the options dialog for RDP when he's asking about VNC is not very useful. –  davr Dec 4 '09 at 23:40
    
I'm showing him how RDP has the features if he's interesting in using it instead. I also told him to check if VNC has those features first before considering a switch. –  John T Dec 4 '09 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.