Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Let me explain the situation: I have wireless router, that connects to DSL modem, that later goes to ISP(by f-connector if it matters). Then I have two problems with it:

1) Wireless router gives the ip addresses like 82.197.xx.xxx and also(!) the default gateway of 82.x.x.x. The thing I don't understand - why is it so, when the local IP of router is 192.168.0.254, so my home network must be within this address pool. For some reason it gives addresses that belong and go straight to ISP. Internet works fine, but why is it so?

2) Second question is more serious - I have gone to internet from my house using several devices for my life here(4-5 devices maybe), but few days ago I tried to connect my friend's iPhone to the internet and it seems that router doesn't want to give address to it. I mean the device can find the network, you click "connect", type password and then nothing, no IP address is given to device. I tried the same with my friend's laptop - no address again. So can it be that the ISP give only limited number of IPs tied to MAC addresses and doesn't use NAT/PAT? If so - how can I forget some devices to use new ones?

Answering expected questions:

Yes, the IP addresses on different devices are different, seems like no NAT/PAT here.

Yes, other laptops can't get the IP address EVEN through Ethernet cable.

The router is in AP configuration mode.

Router is TP-LINK TL-WR702N

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You have your external network interface from your modem connected to your internal interfaces on your wireless router. You need to move the cable from the modem to the WAN port on your wireless router (if it has one). Once done you need to log on to your router's 192.168.x.x IP address and ensure DHCP is enabled, then reboot the router and check to see if you get an internal address.

internal subnets are:

192.168.x.x (/24 subnet) 10.x.x.x (/8 subnet) 172.16-31.x.x (/12 subnet) 127.x.x.x (/8 subnet, loopback interfaces only)

BTW, as it is currently configured is very dangerous, your devices are available directly on the internet, meaning if you have shares on any of your computers they can be accessed by anyone on the web, and you have just handed out your IP to everyone!

Edit

I can see your router has only one ethernet port. What you need to do is log on to your router and follow this guide from tp-link to set the device to router mode:

http://www.tp-link.com/en/article/?id=396

share|improve this answer
1  
So, I understand that configuring properly router mode will fix the problem probably, but why AP mode does not give addresses to some of the devices, while other devices feel fine? –  Samovar Jul 31 at 14:30
1  
This is because, currently, you are being assigned public IP addresses. Your ISP (very generously) seems to allow you several public IP addresses (there are only 4 billion in the world and they are rapidly running out). When set to router mode, your router hands out the IP rather than the ISP doing so. It hands out a private IP (it does not matter if a private IP has a duplicate elsewhere in the world) rather than a public IP (only one of each address can exist in the world). Your router will have enough addresses to hand out to 254 devices, instead of your ISP's 5. –  Alex Berry Jul 31 at 14:32
    
p.s, as you are new I just thought I'd let you know, if a solution works for you please press the up arrow to the left of the post to mark it as helpful, and press the tick icon on the answer provided that solved your issue :) –  Alex Berry Jul 31 at 14:39
1  
What you might find, too, is that your router will not be able to get a DHCP lease, due to the fact all your IPs have been allocated. To fix this, BEFORE you follow this guide, on your windows wireless computer run "ipconfig /release" in an elevated command prompt (type cmd in the search menu on the start bar, right click on cmd and click run as administrator). This will then release the IP address so your router can take it once reconfigured. If you do not do this you will probably find you will have to reboot the modem or wait between 8 and 72 hours for the lease to be released. –  Alex Berry Jul 31 at 14:46
1  
Thanks for mentioning /release command! :D Actually, I don't know why, but just releasing didn't work, I needed to reboot modem also, probably something to do with modem itself, who knows. Anyway thanks! :) –  Samovar Jul 31 at 14:59

It may be a default setting in your router for the IP's handed out for DHCP. Seems a bit odd as your ISP would certainly not want to have to give you an external IP for every one of your devices...

Check the DHCP settings on your router. If I am not mistaken this is your router?
http://images10.newegg.com/User-Manual/User_Manual_33-704-134.pdf
If so, take a look at section 4.7.1. Check the Start/End IP range to see if it is actually handing out IP's based on that higher range. Also, you can check to see if it has a small range such that you will only be able to connect a small number of devices. If so, simply increase the range.

share|improve this answer
1  
the more interesting thing is how ISP could possibly give the IPs if there is router between PC and ISP. Maybe it's AP mode that behaves strangely... OK, I'll try to configure DHCP manually. Thanks! –  Samovar Jul 31 at 14:33
1  
Make sure to check on your connections as Alex mentioned, I think he is right on the money on it likely being that you are incorrectly connected. The DHCP settings may not even be a factor (but you can certainly check them to verify). –  BeepBeep Jul 31 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.