Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why I try to install any program I see "Another installation is in progress. You must complete that installation before continuing this one." error.

Googled the web and found that solution would be to delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\InProgress registry key and reboot. That didn't help me unfortunately. When I open "Services" mmc snapin it shows that "Windows Installer" service is "Started", but "Start/Stop/Pause/Restart" buttons are grayed (the interesting thing is that startup type = "Manual", so I don't really know how to explain that I already have 2 instances of msiexec.exe in memory and one instance is consuming 50Mb of memory.

Looks like there's a serious issue with my installer service - is there any way to fix it (please do mind - I can't install anything!)

Any help would be greatly appreciated.

share|improve this question
add comment

3 Answers

Go grab the Process Explorer from Sysinternals.

You should be able to see the msiexec.exe service running, and if something is in the middle of installing you should see other msiexec.exe children processes. It would be best to allow them to finish, and maybe try to squeak your install in between.

I have seen it before where the .NET Runtime Optimization Service is constantly firing off ngen.exe using the installer service to generate optimized .net assemblies and never allows the installer to use anything else. You can try stopping that service to see if it makes a difference.

share|improve this answer
    
+1 for "squeak"... and a good answer. –  Richard Aug 18 '10 at 10:38
add comment

Have you checked for malware?

The Windows intaller service is normally set to manual and the buttons will be greyed until you change to Automatic.

Two instances of MSIEXEC running seems unusual. do you have AV software running? Is it up to date?

Anything unusual in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\run ?

share|improve this answer
add comment

This could be malware, as @DaveM states.

Have you tried to look into Task Manager whenever your setup is closed? Sometimes you see still somewhere a 'setup.exe'... Sometimes you can't get it away. This is called malware; worms; virusses; what not else.

I guess one of the only things you can do is what @DaveM said; or you're just going to reinstall Windows. If this does not even solve your problems; try thinking better; try thinking more secure; try thinking Mac.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.