Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My motherboard is an Asus P6T and I made sure that my RAM are of the same brand and the same spec. CPU-z can detect all 6 2G modules that I have installed so they are all plugged in properly into the RAM slots. The only thing is that I haven't activated Windows 7 yet, since I am waiting for my SSD to arrive so I don't want to risk being accused of being a pirate when I reinstall Windows 7 onto the SSD.


It turns that two of my RAM modules were not physically installed properly.

share|improve this question
add comment

6 Answers 6

up vote 7 down vote accepted

There could be any number of reasons this doesn't work:

  • Faulty motherboard or memory slot
  • Faulty memory stick, what does memtest say about them all?
  • Issues with voltage, try upping DRAM voltage a bit
  • Issues with heat, try to run it open and with a fan towards the memory
  • A memory speed issue, that motherboard does only support 3 modules at full speed (DDR-1600)
  • Generally flaky BIOS or hardware, try inserting one module at a time and booting, making sure it's deteckted, continue one module at a time until it works or fails - when it fails, try reordering the modules in all possible combinations

Activating Windows should not have anything to do with this, you can easily extend the grace period if needed. However you should not be afraid of activating it either. If you run out of "free" activations you just call Microsoft and get another - they're not going to question you or even ask why (unless you answer their "how many pcs are you running this copy of Windows on?" with something else than one ^^

share|improve this answer
    
But CPU-Z can "see" all 6 of my RAM modules! –  xiaodai Dec 5 '09 at 9:32
    
Yes that doesn't mean they work, at least not after five minutes of google searches on your problem... –  Oskar Duveborn Dec 5 '09 at 12:34
    
You can also delay the activation until you sort out the RAM issues. –  Mr Fooz Dec 5 '09 at 16:02
add comment

Just to rule out hardware issues, you should probably grab a 64-bit Linux or BSD LiveCD and boot into it to see what the memory map looks like (cat /proc/mtrr/ for the gory details on Linux, I think, though I don't have a Linux shell session handy to double-check). If your full 12GB of RAM is not recognized by Linux either, you need to examine your motherboard BIOS and chipset very, very carefully; there are a lot of oddities when it comes to chipsets and available RAM.

The fact that CPU-Z can see the memory modules is more or less irrelevant; what matters is if your chipset can see the actual memory chips.

share|improve this answer
add comment

Open MSCONFIG, open the Boot tab, click Advanced Options, make sure that Maximum Memory is not capped.

alt text

share|improve this answer
add comment

Try download http://www.memtest.org/#downiso to USB or CD and run it on your system to see if all the memory are detected and can be tested.

share|improve this answer
add comment

Have you checked in the BIOS setup that the RAM is recognized correctly by the hardware? Any BIOS setup program I have seen displays the amount of available RAM. You surely will not get it in Windows if it doesn't show up there, so it's the first thing to check (and easy too).

share|improve this answer
add comment

I had this problem, and the issue ended up being the order in which the RAM was installed. In this case, it was a laptop- BIOS would show 12G, but Windows 7 x64 showed "23 installed, 7.34 available". The laptop has 4 slots, 2 under the keyboard and two on the bottom. Switching the two 4Gs to under the keyboard, and two 2Gs to the bottom fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.