Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a T400 with Windows 7 64bit. About 3 weeks ago, the Lenovo update pushed a Bluetooth update that added a 2.1 driver and device experience. Since then, my bluetooth turns itself on whenever the OS comes up (full restarts as well as waking from hibernation). I can turn it of using the <Fn>+<F5> Radio menu, but it just turns itself on again the next time. If I forget to turn it off, it just eats my battery that much faster.

I've been scouring the web and couldn't find similar occurrences. Is this a hardware issue, a BIOS issue (although no reference to BT in any of the BIOS menus), a driver issue or (shudder) a user issue?

Thanks for your help.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Solved with a Lenovo BIOS update... to some degree. Still occurs every once in a while. I've grown to believe it's faulty hardware. Learning to accept something you don't understand is hard :)

share|improve this answer
  1. open the services control applet (start > run > services.msc) and disable the bluetooth service (right click > properties).

  2. download and run Autoruns and disable bluetooth related startup entries.

Autoruns is freeware.

share|improve this answer
    
I've already used a startup monitoring app and none of the ones in there have anything to do with bluetooth. As for disabling the service - I do want to use bluetooth - but on my own terms. I set the 2 services ("Bluetooth services" and "Bluetooth Support services") to Manual - but something still triggers the first. Again, this appeared after a driver update - so I'm looking for a Thinkpad-specific solution. –  Traveling Tech Guy Dec 6 '09 at 2:18
1  
gotcha. that's what i like about ASUS machines, their Tray Utility turns off bluetooth, webcam etc, and the device will STAY off until you change the status. not sure know if DevCon will do you any good, but it's worth a try: support.microsoft.com/kb/311272 –  Molly7244 Dec 6 '09 at 2:39
    
Thanks for the tool Molly, never heard of it before, +1 on the comment. Unfortunately, the BT turns itself on BEFORE it even reaches Windows - yet there's no option in the BIOS screens to turn it off. –  Traveling Tech Guy Dec 12 '09 at 2:33

Check this linke Lenovo BT off

Do the opposite from this solution, e.g. instead of setting it to on, set it to off.

share|improve this answer
3  
Could you summarize the solution in your answer? Links often go dead and another user in the future may need the information. –  jonsca Aug 2 '12 at 3:52
    
Summarize andyou will get an upvote from me, it seems like the Lenovo forum should solve the OP. –  FredrikD Aug 8 '12 at 8:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.