Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed Ubuntu 9.10 on VMware Player 3.00; the host OS is Windows 7.

I can't get Ubuntu in the VMware Player to connect to the Internet. My Internet connection is wired and the modem/router is D-Link DSL-G604T. What can I do to fix this?

share|improve this question
    
have you by any chance installed the virtual box guest addition.. if not install it first by looking at this > mydigitallife.info/… & make sure your adapter of the virtual machine is set to NAT. so that the VM can use internet from host –  AzkerM Jan 15 at 8:41

3 Answers 3

First off, ensure that the guest has a network card and then make sure the status (In Vmware Player) is set to connected.

If you are still having problems, to try and rule out Firewalls or anything else, try setting the network mode (In Vmware Player) to Bridged as this should assign the Virtual Machine its own IP and appear on the network as a stand alone computer.

If you are still having problems, do you have DHCP or fixed settings? If it is fixed, you will need to apply those settings to the guest (unless in NAT mode).

If this does not work, please say in comments and I will try to come up with more.

share|improve this answer

I recently ran into this. My solution was to delete the existing wired network connection from Ubuntu's Network Connection's applet (under System/Preferences) and adding a new connection (using the mac address found in the VM appliance's vmx file.) Then I set VMWare connection type to Bridged.

share|improve this answer

I had this issue with a Windows Server 2003 installation.

Install the Guest Additions/Utilities from inside the VMPlayer control panel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.