Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When browsing sites that uses javascript effects (example is Wordpress' backend. The sliding left menus/panes) are really really slow. Also my local sites that uses jQuery are slow as well.

I got Firefox 3.5.5 running on a WinXP SP2 machine. The specs are Athlon XP 5200+ with 4gb of ram.

I ran Firefox in safemode and disabled all my addons and plugins but nothing has changed.

What do you guys think I should do?

share|improve this question
1  
Switch to Google Chrome. ;) –  Sasha Chedygov Dec 6 '09 at 4:38
    
I wish I could but I use firebug a lot –  ajushi Dec 6 '09 at 4:45
    
Try GChrome, if it works fine we knows it's a FF problem. Really, as a webdev, you should be checking in every browser anyway :P –  Phoshi Dec 6 '09 at 11:37
    
I tried chrome so it's a ff problem. I try every browser but FF is my workhorse :) –  ajushi Dec 6 '09 at 13:41

3 Answers 3

First, let's make sure it's not just a profile issue. Create a new Firefox profile and see if things are still slow without any additional add-ons. (Win+R>firefox.exe -ProfileManager) If it's not, start removing add-ons and restarting until you find the culprit/culprits. (this should be a similar test to safemode, but sometimes profiles get all wonky and you just need a new one)

Okay, if that wasn't it, how about it being a local Firefox issue? Go grab a copy of PortableFirefox and see if it's slow in there.

If that works, check to make sure you are using tracemonkey in your local copy (though your examples shouldn't require the JIT). about:config search for jit make sure javascript.options.jit.content is set to true also search for javascript and see if anything isn't default. You could also just need to backup your Firefox profile and do an uninstall/reinstall.

Check to see if you've got some invasive script checking anti-virus making your life difficult (or several anti-virus/malware packages running at the same time). Disable any and all and try again. Is it also slow in IE (we know it's not in Chrome, how about Safari, Opera), because maybe the sandbox in Chrome is hiding it from something on your system.

share|improve this answer

try firefox beta: http://www.mozilla.com/en-US/firefox/all-beta.html

may need to disable extension compatibility checking.

share|improve this answer
    
The "Add-on Compatibility Reporter" add-on that gets offered on the page that loads on first run after you install the beta will handle the add-ons compatibility checking (requires restart after install). Gives the option to enable/disable regardless of the listed version range compatibility. –  Bonus Dec 6 '09 at 10:38

Do you only have problem when you a lot pages with Javascript opened?

I normally install no-script first thing when I get ff on a new computer / accounts.

It lets me enable JS selectively. Ad serving sites such as doubleclick always disable.

I seldom see website performance problem with > 15-25 pages open all the times for me.

I disable Java. no-script also block flash which help system performance.

share|improve this answer
    
I don't think JavaScript is slowing down his browser; he simply said that JavaScript effects (sliding, fading, etc) are really slow. –  Sasha Chedygov Dec 7 '09 at 4:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.