Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded a file from the internet (I can link to it here, but in the interests of not annoying other users, I won't post the link), and I can't delete the file with the message:

You need permission to perform this action You require permission from the computer's administrator to make changes to this file

Trouble is, I am the administrator and UAC is completely off.

If I go into the Properties/Security tab, I get the message

You do not have permission to view or edit this object's permission settings

Clicking "Advanced"/Owner, it says:

Current owner: Unable to display current owner.

If i try to change the owner, I get the same message:

Unable to set new owner on file Access is denied.
share|improve this question
Did you check if its being used by another process? – Sevki Dec 6 '09 at 16:18
Using chkdsk /f in cmd in parent folder of it. I try and success! – Victoray Sep 23 '14 at 6:04
up vote 37 down vote accepted

Give Unlocker a try. If there is any open file handle it will let you close it so you can successfully delete the file.

alt text

If that doesn't work for some reason, try BootDeleter. It will delete the file for you upon reboot, before Windows has a chance to lock it on you.

alt text

Both utilities are freeware.

share|improve this answer
Boot deleter did it. ty. – bobobobo Dec 7 '09 at 6:45
Boot deleter worked awesome! – Jorin Aug 18 '11 at 14:30
@Jorin glad to hear it :) – John T Aug 18 '11 at 14:31
Unlocker installs the Delta-toolbar and default search engine crap in all your internet browsers:… The "Recent Changes" feature in recent builds of the "Everything" file-system search engine allows you to see what other things Delta Search has broken: – Jeroen Wiert Pluimers Sep 18 '13 at 8:22
To extend on @Jeroen's true comment: some 3rd party download sites even wrap more into the installer. Getting it from the Unlocker website gets one a 393K exe that already includes "Promotional feature: Fully optional Delta toolbar" since version 1.9.2. But a download from MajorGeeks is even 1.0M for the same version; who knows what that things installs... – Arjan Apr 26 '14 at 20:20

Sometimes it just won't let you change permissions because some process is using the file, or if you are trying to edit a folder's properties, then a process has a file that is within that dir or subdir open.

I had the problem described today, and I solved it by opening Process Explorer. Then, I went to the "Find" Menu, and selected the "Find Handle or DLL" option. In the dialog that comes up, I searched for the name of the folder I was having issues with. The search results told me which process had an open file within the folder. I killed the process, and then I had no problems with that folder's permissions.

share|improve this answer
Sometimes when IIS failed compilation of a web site DLL, administrator cannot delete or even change permission of the resulting file. Process explorer search also turns out empty. Doing iisreset in the command console unlocks the file, and strangely deletes it too, allowing us to recompile the file. – YudhiWidyatama Apr 9 '14 at 12:47

Try Ultimate Windows Tweaker, which adds a "take ownership" element to the context menu.

alt text

Portable application, does not require an install.

share|improve this answer
This tool will not solve the problem. The underlying security issue is that Windows does not consider the user to have sufficient rights to take ownership, and this tool, while convenient, cannot subvert that. – Gavin May 20 '14 at 8:56
@Gavin What privilege do Administrators not have that they need to be granted? Under what circumstances would Windows not consider an Administrator as having insufficient rights to take ownership? – Ian Boyd Jan 28 '15 at 15:17

I have had this issue a couple of times. Closing and restarting explorer resolved the issue. A quick and dirty solution, but it worked.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .