Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a development setup from this tutorial: Build Your Own Dev Server with VirtualBox.

But what I can't figure out is how to share a folder on my Ubuntu virtualized machine with the host Windows 7. I want to use a Windows text editor to edit code that's on my Ubuntu server.

I've tried using the Shared Folders setting, adding "/var/www" but it says that the path is not absolute. When I click on "other", it only allows me to browse folders on my Windows 7 host.

Both the host and guest are 64-bit OS.

share|improve this question

migrated from stackoverflow.com Dec 6 '09 at 18:30

This question came from our site for professional and enthusiast programmers.

Install the Guest Additions for the guest OS and configure the shared folder(s) on the host OS. You'll find these options in the Devices menu.

alt text

share|improve this answer

I had a lot of trouble with this, but found a pretty easy workaround. It involved setting up a second network adaptor for the guest os. Have 2 adaptors on system: 1> NAT and 2>Host-Only Adapter connected to VirtualBox Host only network adaptor (this was selected from dropdown list). This allows two things...1 maintains connection to the internet for updates, etc., and 2 allows guest to be visible on workgroup in win7 host OS. Now you can share folders from the guest OS to windows =>since I couldn't get it to work the other way around. This was useful for me as I rarely transport things from vista to ubuntu anyway. With mindterm installed on Windows and an openssh-server installed on the guest OS, I was then able to enable two-way file tranfers between win7 and ubuntu, which was really ideal, using the SFTP plugin.

share|improve this answer

Here is your perfect solution with just "NAT".

Quoted verbatim from http://blogs.oracle.com/tao/entry/virtual_box_shared_folder_between:

  1. Add folder(s) to shared folder menu.

    It is important to write down the folder names at this step.

  2. Boot guest system, open a terminal and type in the following commands

    sudo mkdir /mnt/tao_xp
    sudo mount.vboxsf TAO /mnt/tao_xp
    

The shared folder would be accessible now: read & write!

share|improve this answer

What worked for me was switching my "Network Adapter" in VirtualBox from "NAT" to "Bridged". This can be done in VirtualBox's menu, "Devices" -> "Network Adapters". All of this needs to be done after installing "Guest Editions". For some reason, my install defaulted to "NAT", which I never could get to see my networked computers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.