Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Vista says now: "Desktop folder location is not available..."

Its default location appears to have changed. How do I change it back? It should be simple in theory, however I cannot find a simple answer on the net. Not even from Microsoft folks. There must be an easy way to do this without "hacking" registry entries.

Does anybody know how?

Thanks!

share|improve this question

2 Answers 2

up vote 5 down vote accepted

To move your Desktop folder to a new location:

  • make sure the target folder exists; create it if it doesn't
  • open your User folder
  • right-click on the folder Desktop
  • select Properties
  • open the Location Tab and click Move
  • now pick the new location and click Apply

You may be prompted to copy, move, overwrite files if they already exist in the new folder.

share|improve this answer
1  
Please edit your answer to indicate first step to: "create a Desktop folder in the path displayed in the error message" then navigate to it right click on it and select Properties ... once edited I will accept it as the perfect simple answer. Thanks! –  Notitze Dec 7 '09 at 15:36
  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Right-click Domain, and then click Properties.
  3. Click the Group Policies tab, click Default Domain Policy, and then click Edit.
  4. When Group Policies starts, click User Configuration, click Windows Settings, and then click Folder Redirection.
  5. Right-click Desktop Folder, and then click Properties.
  6. You can now configure the location of the Desktop folder. In the Settings box, click Advanced - Specify the location for various user groups, and then click Add.
  7. Click the Browse button next to the Security Group Membership box, and then click a group from the domain list.
  8. Click Target Location Folder, and then use a UNC path to the location where you want the Desktop folder to be located.
  9. Click the Settings tab. By default, both of the following settings are enabled: o When enabled, the Grant the user exclusive rights to Desktop check box sets permissions on the folder for the User and System to full permissions. If you click to clear the check box, no change is made to the permissions on the folder. o When enabled, the Move the contents of Desktop to the new location check box moves the contents to the new location. If you click to clear the check box, then the contents remain where they are.
  10. In the Policy Removal box, click either Leave the folder in the new location when the policy is removed, or Redirect the folder back to the local userprofile location when the policy is removed. By default, the first option is selected.
  11. Click Apply, click OK, and then quit Group Policy Editor.
  12. Log off the administrator account, and then log on again.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.