Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having some trouble with SOCKs proxies and Windows. Currently I have mapped my local port 22222, to my ssh server at home. When I configure my browser to manually push all traffic through the tunnel it works great and my IP address appears to be my home IP.

However, I run into some trouble when I try and push all traffic through the SSH tunnel; mainly my laptop selectively choosing what it's going to be pushing through the tunnel. Some traffic appears to be routed to my home, some traffic isn't.

I'm on Windows 8.1, and I've setup my sock=127.0.0.1 port 22222. I opened a browser, with default configurations, and check IP, and it appeared to work. My home IP was displayed, I recheck about 1 min later and my current location's IP is displayed. And it flip-flops every so often.

I'm having no problems tunneling the connection to my home, and reaching the Internet from a browser. But, I am having trouble setting up all traffic from my laptop to use the SSH tunnel. Any ideas How to solve this without going to step 2..

Step 2: I got the idea of tethering all my traffic through my phone's SSH tunnel, and that way I wouldn't have to modify to LAPTOP connection at all. The phone is rooted and using the SSH Tunnel app to forward all traffic. But when I tether only get the local address, IE the address of the current location. Any ideas what I would have to modify on the phone to get this to work?

share|improve this question
    
How are you specifying proxy settings on the laptop? System wide or app by app? Some applications don't appropriately use a system wide setting. You may need to configure your browser setting specifically. Mentioning which browser may also be helpful. –  0xDAFACADE Aug 14 at 14:37
1  
On Windows 8.1, I'm using internet options to specify a socks proxy as 127.0.0.1 port 22222. Firefox, Chrome and IE seem to work fine when I specify a proxy in their respective options/preferences. It's just without that proxy specification the global internet options aren't working. I also tried to launch WoW and Steam, I couldn't get past the login screen with either. –  Headless Bunny Aug 15 at 2:49
    
You may want to look at this as it seems to have the answers you need. The system proxy settings don't force anything through a proxy, they're just there so that other programs can choose to support proxy settings without needing to implement them separately inside themselves. Not all do, so external solutions may be required (Privoxy is quite reputable and widely used, and particularly has been known to work with Steam). –  0xDAFACADE Aug 15 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.