Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running SuSE 11.1 w/ KDE 4. Screensaver keeps blanking out my screen on me and I can't find a setting to turn it off. A secondary issue is that it also eventually locks my screen on me if screen is blanked for awhile. Would like to make it stop doing that too! Hard to use it as a monitoring/display session if it keeps blanking out my screen!

share|improve this question

migrated from serverfault.com Jul 18 '09 at 14:09

This question came from our site for system and network administrators.

3 Answers 3

up vote 5 down vote accepted

Open Configure Desktop/Personal Settings.

Go to Advanced > Power Management > Edit Profiles, and in the setting for the profile you are using (or all profiles) change the option for When the system is idle for more than XX min to Do nothing.

In a default install it is set to Lock screen, and this overrides ANY timeout and password lock settings you have set for a screensaver in General > Desktop > Screensaver (particularly if you have unchecked Start automatically, or set the timeout to a period longer than the timeout in the Power Management settings).

This answer was copied from user Clayton on the opensuse forum post titled Screen blanking/locking and 11.1.

share|improve this answer
    
I was just repeatedly overlooking the "Configure Desktop" icon I guess. Had to disable the screensaver under Desktop/Screen Saver AND do the above power management profile change. Thanks! I'm a long time Linux user and my biggest gripe is the screensaver controls are often hidden and sometimes don't even work right. IMNSHO, a OS used primarily for servers (argue all you want, we all know it's true) shouldn't ship with screensaver ON by default. Needs to be off for monitoring purposes anyways. If I want my screen off, I'll reach over and push the power button! :-) –  Brian Knoblauch Jul 15 '09 at 11:41

The Easiest Method for My device was to open the system menu. Under System, which is on the right hand side you click "control Center". Click "Screensaver" under look and feel; Alternatively, you can type "Screensaver" in the search box. On the bottom of the screen saver preferences window there is check boxes un-check "Activate Screen Saver When Computer is Idle" and "Lock screen when screensaver is active". When you are done click "Close".

share|improve this answer

on 11.3 i went to screen locker. opensuse kde can do a seach for locker and it will pop up

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.