Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot up my corporate laptop, the "Automatically detect settings" option is ticked. This setting never works and I need to untick it before I can access the Internet.

I've tried looking for a registry entry so I can run a script on boot up that turns this setting off. I enabled the setting and exported a branch, then disabled the setting and exported. A diff comparison shows these two as identical between the two exports:

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]

Does anyone know what the setting is? I'm running Windows 7.

share|improve this question
up vote 2 down vote accepted

You might disable proxy caching, as described here:
How to disable automatic proxy caching in Internet Explorer

It's also very puzzling that the following registry key doesn't change:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
As the difference is only one bit, it might have been overlooked.

See this thread for an example of differing values (skip to the very end):
Registry key for IE's "Auto Detect Settings" option
Note: If you can't see the ending comment, search this article through google and click on it. This is a particularity of experts-exchange.com.
You can use the info in this thread to build a batch script to reset the registry to your correct values.

share|improve this answer
    
Though using someone else's registry settings is a bad idea for this unless you want their entire proxy server settings too, so you'll want to save your own registry setting out. – Polsy Dec 7 '09 at 9:10
    
@Polsy: You're absolutely right. My intention was only to demonstrate that other people do see a difference. I've clarified my answer. – harrymc Dec 7 '09 at 10:11
    
I logged in today and it worked fine. I'll keep testing and come back once confirmed. – Alex Angas Dec 8 '09 at 4:03
    
Seems to be fixed with the first link you gave, thanks! – Alex Angas Dec 10 '09 at 21:57
1  
Short version: you need to clear the first bit of the ninth byte in that registry key, by taking 8 off its value, e.g. change "XX XX XX XX XX XX XX XX XB ..." to "XX XX XX XX XX XX XX XX X3 ..." (or change 9 to 1, D to 5, or F to 7) – Andrew Swan Nov 23 '10 at 5:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .