Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Inspiron 1501 that I've installed 64bit Windows 7 on. It's running beautifully, but I am stuck trying to update the BIOS. Dell only provides the Windows BIOS flash utility and when I try to run that I get the Error Code: 1275 which I've narrowed down to being an issue with 32 vs. 64 bit (I think). I've tried using my USB DOS boot drive but the BIOS utility complains that it will not run in DOS. I'm running the flash utility as an administrator and I've tried all of the compatibility settings.

Does anyone have any suggestions on what I can try to update the BIOS on this machine?

share|improve this question

5 Answers 5

up vote 2 down vote accepted

A simple fix:

Use a spare hard drive, any size will do. Re-install any Dell supported 32-Bit version of Windows only, no other software required. Then install the Windows-only BIOS Flash upgrade and upgrade the BIOS.

Then swap your original drive back to use your 64-Bit Windows.

share|improve this answer
    
I agree with ChicoF's answer. I bought a used Dell Inspiron 1501. While it had Windows Vista I upgraded to the latest BIOS update. Later, I upgraded to Windows 7 64 bit and I have no problems at all. –  user95712 Aug 27 '11 at 9:07

How have you installed 64bit Windows 7 on a Dell Inspiron 1501?
Dell support only admits to Vista 32bit and XP on this model.

I believe the BIOS is therefore the least of your future worries. I would really advise to go back to a 32bit OS, as a 64bit OS won't have any appreciable advantage on this machine. You can use Win7 32bit, as the Dell Vista drivers are compatible with it.

share|improve this answer
    
I have to agree. Just because it can be done, doesn't mean it should be done. There is a reason suppliers only support certain OS's on their hardware. –  Diago Dec 7 '09 at 14:16
3  
It's a 64 bit chipset - why wouldn't windows 7 64bit run on it? And as for Dell support admitting anything, that's hardly a reason not to do something. They're more worried with covering themselves legally than providing accurate information. –  Chuck Dec 7 '09 at 17:50
    
The problem with 64bits is as always: drivers, drivers, and BIOS as you've discovered. –  harrymc Dec 7 '09 at 18:23
    
windows 7 comes with MOST every driver. i have a dell inspiron 1420 with windows 7 64 bit. and with the memory hacks it deff runs great with 2 gigs. i play games and i have a few games that are 64 bit and do take an advantage from the 64 bit processing. –  mike Dec 10 '09 at 8:28
    
That's the story with 64bits OS for the moment : it works great until one happens upon something that doesn't - I think this thread proves it. But why insist upon 64bits on a machine where it's not any better than 32bits? –  harrymc Dec 10 '09 at 8:41

To elaborate on what Systech said, sometimes the BIOS goes through a version update simply to follow a hardware update. Therefore, it's not unheard of that a newer BIOS may not work with an older revision of your motherboard's PCB.

share|improve this answer

There is also no resulting 'performance increase' from a BIOS upgrade, as it has been said, if it ain't broke don't fix it! Most BIOS updates are only necessary when new hardware is not detected at boot.

Event then those are rare cases, and mostly result in updates past the products intended life-cycle.

share|improve this answer

I am running into the same problem. I have 2 1501s. The first one updated the bios on vista 32bit with no issues. Running xp 64bit on my new 1501 isn't working. I may install a 32bit just to update the bios.

Yes dell didn't make running a 64bit OS very easy. However I now have my first 1501 running xp 64bit with all drivers (including video) and 8gb of RAM! Yes eight gigs.

share|improve this answer
1  
please can you advise to what memory make and model your using please i have a Dell Inspiron 1501 ive updated the bios to 2.6.3 A16 which is the latest Bios version i was able to find. I currently have 2x 1Gb Infinity memory in this, but i wish to upgrade to 8Gb. I have purchased for £80 from ebay Komputerbay 8GB DDR2 SODIMM (200 pin) 667Mhz PC2 5400 / PC2 5300 CL 5.0 memory its just a generic brand but this has does not work. The processor in this machine is a AMD Sempron 3500+ thanks regards Richard. I think it could be helpful for others –  user113217 Jan 11 '12 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.