Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Win7 Pro x64 machine sometimes will begin using all memory and then becomes unuseable. I have 8GB installed, and "normal" is for 2GB or so to be used. Sometimes, I can see in my memory usage graphs (gadget) that it spikes all the way up to 8GB within 30 seconds and then constantly has activity on the HDD as if the problem is still going on. The computer is unuseable at this point and I must reboot.

It doesn't happen often or anything, but it is very annoying. When it has happened, I am using IE8, Chrome, or Firefox...it doesn't seem to matter. Sometimes it does it when no apps are running at all.

My config: Core2Quad Q6600, stock speed Nvidia 780i MSI motherboard, stock speed 8GB Corsair XMS2800, stock speed Nvidia Geforce GTX295, stock speed Soundblaster Xfi Platinum PCI Avermedia Duet dual ATSC/QAM PCIe NEC PCIe USB2 controller (ATI DCT not compatible with 780i) ATI Digital Cable Tuner with SDV box 150GB WD Raptor, 5 other hard drives, LG BD-RE drive

What's always running: Steam, Logitech KB/M tray apps, AVG

share|improve this question
add comment

8 Answers 8

up vote 1 down vote accepted

this is happing with ALOT of Windows 7 systems and it has to do with the wmpnetwk.exe. my friend streams media to his computers and Xbox. we see that this process uses one core and ALL of the memory and the computer crawls to a stop. Start up in safe mode and turn OFF media sharing. pressing ctrl+shift+esc will bring up the task manager and look if this is indeed the problem. at least this might get you going enough to find another solution if this doesn't help... Good Luck!!!

share|improve this answer
    
It's not that exact process, but it is always one of the ehome processes. If I reboot the machine the problems don't happen...they only happen after 12 hours or so of leaving the machine on. Works for now until MS plugs the leak. –  Stephen Dec 26 '09 at 17:03
    
so i got the check? .. but no point up?? did it fix the problem? if its not that, then use msconfig.msc to stop the unwanted process. –  mike Dec 27 '09 at 6:54
add comment

Use Task Manager to find the guilty program:

Go to the processes tab, then the menu entry of View / Select Columns, put a checkmark next to "Memory - Working Set", and click OK. Back in Processes, click twice this column to sort it by descending order.

Watch this when the problem happens.

share|improve this answer
    
Task Manager is not available. The PC grinds to an absolute halt. Mouse still works though, but info on the screen is no longer updated. –  Stephen Dec 7 '09 at 16:59
2  
The trick is to start Task Manager before this happens, and have it either visible all the time or minimized. –  harrymc Dec 7 '09 at 17:35
add comment

Run Task Manager before this happens, set it to always-on-top, sort processes by VM Size. (Task Manager automatically sets its own priority as 'high'.) Then wait for the "explosion" to happen.

share|improve this answer
add comment

After a long search for why ehvid.exe would use all available resources on my Windows 7 64bit machine, the solution for me was removing the thmb directory which was tried due to a suspicion there was a corrupt TVThumb.db

cmd.exe /c "rmdir C:\ProgramData\Microsoft\eHome\thmb /s /q"

Unsuccessful attempts included 1, 2, 3, 4, 5, 6, 7:

  • ending the process tree
  • waiting out the ehvid.exe to 'finish'
  • uninstalling patch kb955519
  • deleting all files in Recorded TV
  • deleting folder named something like C:\ProgramData\Microsoft\eHome\mcepg#-# and file named something like C:\ProgramData\Microsoft\eHome\mcepg#-#.db
  • installing different codecs
share|improve this answer
add comment

I suggest opening up Task Manager (Start -> type taskmgr -> Enter) and checking what application is using all the memory when it happens.

share|improve this answer
    
Task Manager is not available. The PC grinds to an absolute halt. Mouse still works though, but info on the screen is no longer updated. –  Stephen Dec 7 '09 at 16:59
1  
Quicker way: Press ctrl+alt+delete and click 'start task manager'. Even quicker way: press ctrl+shift+escape –  davr Dec 7 '09 at 16:59
add comment

Does unusable mean Task Manager doesn't run?

Another approach... start removing devices and/or device drivers one by one, until the problem goes away. This takes a while, but usually works.

share|improve this answer
    
Task Manager runs, but when it goes into "memory usage explosion" mode nothing works as the HDD is busy writing said explosion to virtual memory for hours and hours. –  Stephen Dec 7 '09 at 17:02
add comment

Steam is a hog. If you have problems after ending steam, then you need to look at AVG. If you still have problems, you may need to check out services. If all else fails, get more RAM or increase your page file. Both aren't that difficult.

share|improve this answer
    
RAM and page file are 16.5GB together! –  Stephen Dec 7 '09 at 18:10
    
Steam isn't that much of a hog. Any more than 1gb of RAM and you won't notice it. OP has a little over 1gb. –  Phoshi Dec 7 '09 at 20:08
    
Use MSCONFIG to find out what services are running. If you see a particular one you don't reckognize, google it. If it's unneeded for you, tell it not to start. –  Nathan L. Dec 9 '09 at 18:30
add comment

You might be better running perfmon than task manager. You can set that up to actually log the stats of all the processes running. There's another stack overflow article explaining how.

That means you'll need to start perfmon when you initially log in (or start it from your startup programs maybe) and get it logging then just minimise it. Hopefully when some naughty process kicks in and starts gobbling all the memory perfmon will log it's actions which you can then look at after a reboot.

P.s If you haven't heard of perfmon it comes with windows (and always has) although not many people know about it.

share|improve this answer
    
the culprit process is "ehvid.exe" which is part of Media Center. I was able to start Task Manager and saw this eating relatively little CPU, but over 3GB or RAM before everything went south. –  Stephen Dec 8 '09 at 5:00
    
Ah, that's a well known system hog. If you google it, you'll find alot of people complaining about how much system resource it uses. I don't suppose this happens when you start recording a program does it? –  Benj Dec 8 '09 at 9:17
    
No, actually long after a recording has been made and when the TV tuners are not even in use! –  Stephen Dec 8 '09 at 19:56
    
The problems seem to have gone away after removing my Avermedia HD Duet. I think the card is defective as it hasn't been stable holding a signal recently. It's replaced with an Avermedia Combo tuner and no issues yet. –  Stephen Dec 9 '09 at 23:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.