Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Anyone know why doesn't the Windows command prompt window maximize to the full screen size?

To the best of my knowledge, even in the new Windows 7 the command prompt window(cmd.exe) doesn't maximize to the full screen size like all other windows. This behavior is quite annoying for me, and I'm sure to many others as well.

Note: The size of the command prompt window can be changed, but the size remains fixed regardless of the screen size.

share|improve this question

migrated from stackoverflow.com Dec 7 '09 at 21:54

This question came from our site for professional and enthusiast programmers.

6 Answers 6

By default, each line of the command prompt's buffer is only 80 characters wide. If a program produces an output line of more than 80 characters, it is split into multiple lines of the buffer, so there's no point to having a command prompt window more than 80 characters wide.

You can change the size of the buffer on XP by going to the system menu > Properties > Layout tab > Screen Buffer Size. I usually leave mine set at 500x999 because I hate the default line wrapping (I prefer scrolling). A side effect of this is that you can now maximize the window to the full screen size.

share|improve this answer

You can get around this by wrapping cmd.exe within Console2.

Console2

share|improve this answer
    
nice shell. what's your prompt? :) –  naxa Sep 5 '13 at 13:24
    
@naxa: I got that image from the web, but that's PowerShell there, but you can see other tabs for bash, Metasploit, VMware vSphere and Python as well. –  paradroid Sep 9 '13 at 16:02
    
thanks for pointing this interesting info out! however I meant this part by 'prompt': [C:\]<newline><count># , where <count># is yellow. Not sure if this is a powershell default but I don't think so. –  naxa Sep 9 '13 at 16:51
1  
@naxa: You can easily change that. In this answer I mention how to change the colours, but to do the same with the prompt you need to use the prompt function superuser.com/a/417552/8972. Just use search here or on StackOverflow. –  paradroid Sep 9 '13 at 17:00

The reason is that the command prompt is owned by a specific subsystem (csrss.exe) in the windows architecture which is different from the normal Windows subsystem (win32k.sys). Because of this, command prompt windows behave differently then normal windows. You'll note that amongst other annoying behavior, that setting properties for a prompt will only apply to prompts launched via whatever method that particular prompt was launched with.

Why this is, I have no earthly idea.

share|improve this answer

It doesn't maximize to the full width of the screen because the terminal window is a fixed number of characters wide.

share|improve this answer
2  
True, although there's no real reason for this is there. After all an X-Term on Unix will just vary the size of the terminal. Also an X-Term running in Cygwin/X running a dos prompt can be resized to any size and therefore maximised. –  Benj Dec 7 '09 at 19:04
    
And why is that @Anon? –  Antoni Dec 7 '09 at 19:05
    
You'll notice when you do change the width of the terminal in the properties page, it doesn't change the wrapping of previous lines. Evidently, Microsoft thought consistent line-wrapping across maximization would be preferable to the alternative. –  Anon. Dec 7 '09 at 19:09
    
Some terminals (urxvt and the OS X terminal) will reflow the lines when you resize it, but others just mangle and erase them. –  Josh Lee Dec 7 '09 at 21:57

You can press Alt + Enter to toggle full screen.

share|improve this answer
3  
Not as of Vista. –  Graeme Perrow Dec 7 '09 at 19:02
    
Good to know. I've not used any version of Windows more recent than XP. –  recursive Dec 7 '09 at 20:06
1  
And it looks unnaturally ugly. Wide fonts, ugh ... –  ldigas Dec 7 '09 at 23:50
    
My console windows are 120×45 ... have fun using that in fullscreen mode :-) –  Joey Dec 8 '09 at 1:29
    
Doesn't work with Windows 7. –  moose Jan 18 '13 at 17:33

You can try DOSBox to make cmd.exe go full screen.

share|improve this answer
3  
No you can't. DOSBox is an MS-DOS emulator. –  paradroid Oct 19 '12 at 22:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.