Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to share a folder on the Mac (Leopard) to my Windows XP laptop. I went into System Prefs, clicked on Sharing, added the folder called TwoTB and it seemed to work (more or less). That is all it took.

Then all of a sudden, clicking on a \\macmini\TwoTB started asking for a password. I tried entering my userid/password - did not work. I tried creating a new person in the Sharing applet complete with a password. Tried entering that on the WinXP laptop - still did not work.

Simply hitting \\macmini used to bring up the list of shares, now it asks for a password.

What am I missing?

share|improve this question
    
For the username and password have you tried entering \\macmini\username instead of just your username? –  Chealion Dec 8 '09 at 5:15
    
Tried that approach: nothing. Btw, not \\macmini\username, but simply macmini\username should do the trick, but it does not. –  AngryHacker Dec 8 '09 at 22:10
add comment

1 Answer

up vote 4 down vote accepted

It sounds like guest connections got disabled. The checkbox to reenable it is in System Preferences -> Accounts pane -> Guest Account in the sidebar -> "Allow guests to connect to shared folders".

BTW, if you want to allow non-guest access to the shared files from Windows (i.e. get it to accept the account passwords), you need to enable Windows compatability for each account in System Preferences -> Sharing pane -> File Sharing -> Options -> the list of user accounts under "Share files and folders using SMB (Windows)".

share|improve this answer
    
All the options you mentioned we turned on. Still nothing. –  AngryHacker Dec 8 '09 at 22:12
    
Got it working. I went into Sharing, then Options, then added a checkbox under my name. Then I could log in with my name mac name. It still does not explain why Guest Sharing does not work, but that's for another question. –  AngryHacker Dec 8 '09 at 22:50
    
Didn't provide the answer, but good effort nonetheless, accepted. –  AngryHacker Dec 8 '09 at 22:51
    
If the guest checkbox is on but you can't connect, there may be something weird in the config files; first thing to try is turning guest off & back on to see if that fixes it. If not, and you want to dig, check the config files: /var/db/smb.conf should contain lines that say "auth methods = guest odsam" and "map to guest = Bad User"; /var/db/samba/smb.shares should contain a bunch of sections for users' public folders, each of which should include "guest ok = yes". –  Gordon Davisson Dec 9 '09 at 6:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.