Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem

In MS Office 2007, drawing objects snap to the grid differently depending on whether I move the object up or down.

Steps to reproduce

  1. Create a new PowerPoint document.
  2. Click the ribbon's "Home" tab (if necessary).
  3. Make sure the font is "Calibri (Body)" and the size is 18 pt.
  4. Find the Drawing section of the ribbon's Home tab and go to Arrange/Align/Grid Settings...
  5. Make sure "Snap objects to grid" is checked, "Snap objects to other objects" is unchecked, Display grid on screen is checked, and Spacing is 0.083 Inches.
  6. Click OK.
  7. Select "Text Box" from the Drawing palette.
  8. Click on the screen.
  9. Type "This is a text box".
  10. Click anywhere on the border of the text box (border should change from dashed to solid).
  11. Press up arrow repeatedly until the top border gets close to a grid line.
  12. Now press up arrow one more time.
  13. Now press down arrow twice.
  14. Now press up arrow one more time.

Discussion

Do you notice that sometimes the text box moves perhaps one pixel up or down, and other time it moves a full grid unit?

I believe this happens because the height of the text box if 4.0" which is not an even multiple of the grid size (which is 0.083 inches). So, when you move the object up and down, it is sometimes trying to line up the top of the object with the grid and other times trying to line up the bottom.

This behavior is completely not what I want. I would like it to always line up the upper-left corner of the object with the grid, which I think will at least bring us up to early 1990s technology (1990 was the year I learned how to use MacDraw).

Question

Does someone have a way to outsmart this two-way grid-snapping "feature"?

share|improve this question
add comment

3 Answers

Just press and hold CTRL key while moving the object. To test it make sure you enable Gridlines from View menu, and zoom to 200% - now you should see the difference pressing the CTRL key while moving the object.

share|improve this answer
    
I must be missing something. If I use Ctrl with the arrow keys, it just moves pixel by pixel (I get no grid snapping at all). If I use Ctrl while dragging the object with the mouse, it duplicates the object. –  devuxer Dec 8 '09 at 18:01
    
Yes, Ctrl key moves it pixel by pixel. This is the only way to move the object between grids more precisely. Ctrl and dragging copies the object - it is the same for all Office suite. I think you should consider decreasing the spacing to minimum, not 0.083 inches –  Nicu Zecheru Dec 8 '09 at 18:34
add comment

Hold Alt while you're dragging and you can do pixel by pixel movements.

share|improve this answer
    
That's a great tip, but I actually want grid snapping. I just don't want it to try to snap all sides of the object to the grid when it should just be snapping the top and left. –  devuxer Dec 8 '09 at 18:03
add comment
up vote 0 down vote accepted

I think I figured it out:

  1. Right click on the text box and select Format Shape...
  2. Select Text Box
  3. Make Vertical alignment Middle Center and set Autofit to "Do not Autofit".
  4. Resize the text box by dragging each edge until it snaps to the grid.

Now when you move the text box, it will snap properly no matter which direction you move it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.