Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Eclipse doesn't start anymore. I get a dialog box that points me to a log file with the following entry:

!SESSION 2009-12-08 08:49:16.263 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_17
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.php.product -keyring /Users/cheezy/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.php.product -keyring /Users/cheezy/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 4 0 2009-12-08 08:49:19.993
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
    at org.eclipse.swt.graphics.Device.getFontList(Device.java:369)
    at org.eclipse.jface.resource.FontRegistry.filterData(FontRegistry.java:465)
    at org.eclipse.jface.resource.FontRegistry.createFont(FontRegistry.java:499)
    at org.eclipse.jface.resource.FontRegistry.defaultFontRecord(FontRegistry.java:563)
    at org.eclipse.jface.resource.FontRegistry.getFontRecord(FontRegistry.java:673)
    at org.eclipse.jface.resource.FontRegistry.get(FontRegistry.java:613)
    at org.eclipse.jface.resource.JFaceResources.getDialogFont(JFaceResources.java:273)
    at org.eclipse.jface.dialogs.Dialog.initializeDialogUnits(Dialog.java:925)
    at org.eclipse.jface.dialogs.TitleAreaDialog.createContents(TitleAreaDialog.java:131)
    at org.eclipse.jface.window.Window.create(Window.java:431)
    at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
    at org.eclipse.jface.window.Window.open(Window.java:790)
    at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(ChooseWorkspaceDialog.java:91)
    at org.eclipse.ui.internal.ide.application.IDEApplication.promptForWorkspace(IDEApplication.java:275)
    at org.eclipse.ui.internal.ide.application.IDEApplication.checkInstanceLocation(IDEApplication.java:223)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:103)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

I did clean up my font list in Font Book by disabling duplicate fonts. I also upgraded to Mac OS X 10.6.2.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

The problem is most likely caused by a missing font, either by the "cleaning up" of the duplicate fonts, or by the upgrade to OS X 10.6.2.

I fixed it by removing the org.eclipse.core.runtime directory in the configuration dir next to the Eclipse executable. A post in the Aptana forums suggests removing .fonts.cache-1 and the .fontconfig dir in your home directory, but that did not work when I tried that first. The Eclipse config directory is recreated when restarting Eclipse, the latter are not.

The fonts I disabled yesterday were re-enabled today (in Font Book), maybe because of the OS upgrade.

share|improve this answer

In my case, the problem was caused by duplicated fonts. Using the Font Book tool, it was easy to fix.

To resolve this, do the following:

  1. Open the Font Book tool ( Applications > Font Book )
  2. From the menu, click Edit > Select Duplicated Fonts
  3. The duplicated entries will be selected
  4. From the menu, click Edit > Resolve Duplicates
  5. Relaunch Eclipse
share|improve this answer

This procedure does the trick for me:

  1. Close all running applications
  2. Start Terminal from Applications > Utilities > Terminal
  3. Run the following and enter your admin password:

    sudo atsutil databases -remove
    
  4. atsutil server -shutdown to shut down the font registration system
  5. atsutil server -ping to restart
  6. Log out and back in

I'm using Aptana Studio 2.0.5.1278522500 on SL 10.6.4.

share|improve this answer

Those methods didn't worked for me; I had to clear the font cache in the command line. Follow the instructions below:

http://www.macworld.com/article/139383/2009/03/fontcacheclear.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.