Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a firefox addon that is not supported by the latest version installed on my computer. I know there is a way to use this by editing the xpi file,but I can't even download the xpi files from the mozilla addon site (the "get addon" button is disabled)

Can someone please help me out here?

Edit: This for example - https://addons.mozilla.org/en-US/firefox/addon/5462

share|improve this question
    
Can you link the addon? If so I might be able to find a link that you can paste into IE or Wget to download it... –  Mokubai Dec 8 '09 at 11:20
add comment

9 Answers

I use the Nightly Tester Tools, instead of tweaking the XPI file: https://addons.mozilla.org/en-US/firefox/addon/6543?src=api

This allows you to mark an addon as compatible (something like that), which is pretty much a necessity for nightly build testers. You should use it with caution, of course.

share|improve this answer
    
Don't use it on All-In-One Sidebar. It really isn't compatible with 3.6 and will totally break your browser's layout. –  Macha Dec 29 '09 at 17:03
    
See my answer about Addon Compatibility Reporter. Nightly Tester Tools's developer says: "The advanced extension compatibility fixing has been removed starting with Nightly Tester Tools 2.5, instead there is a checkbox to disable extension compatibility checking for all addons. Users are encouraged to install the Addon Compatibility Reporter which does the same thing but lets you also report feedback on compatibility to extension authors." –  Nicolas Raoul Apr 18 '11 at 8:49
add comment

Try scrolling down the addon page to the bottom, there is a link named "older versions". If you click this link you will be taken to a page which lets you download all versions plus the latest.

share|improve this answer
    
Already +1'd. Confirmed on my copy of Firefox, main page says "Not Compatable" and refuses to install, but scrolling to the bottom of the page and selecting "Older Versions" allows you to attempt to install both experimental and the current versions. –  Mokubai Dec 8 '09 at 18:45
add comment

You can simply set the value of extensions.checkCompatibility to false (it's a about:config preference).

share|improve this answer
add comment

Someone posted a link to version 0.2.0 in the comments for the addon... Bosskey

http://ftp.mozest.com/addons/extensions/boss_key/boss_key-0.2.0-fx+fl+ns+tb-windows.xpi
share|improve this answer
add comment

I've done this before. It has the potential to break things if the addon is not actually compatible, but it works fine a lot of the time.

  1. Download and install 7zip
  2. Right-click on the .xpi file, and choose 7zip->open archive
  3. Right-click on install.rdf, and choose edit
  4. Find this code: <!-- firefox --> <em:minVersion>1.5</em:minVersion> <em:maxVersion>3.*</em:maxVersion>
  5. Modify the maxversion to suit your needs
  6. Save the file. It should be updated inside the archive automatically.
  7. Close notepad and 7zip. Open the .xpi file in firefox. Hopefully it'll install!
share|improve this answer
add comment

A summary of the answers, with a little more:

First you need to set your firefox to accept "outdated" extension: use the more simple Nightly tester tools (credit MetalMikester) or the MR Tech toolkit with extended features (I like the extensions dropdown button and some others) (credit: harrymc). Or, as you said, you could manually edit the xpi file (credit: nhinkle) but it's more fastidious

Next (and more specific to your question) you need to avoid the site protection: use the "older version" in the bottom of the page (credit: CGA) or create a mozilla acount, you will have a "ignore version check" link in the button (credit me)

share|improve this answer
add comment

Hit up the All Versions link at the bottom. Check the box to install the experimental add-on. The Add to Firefox button should go from gray to green. Now right-click on the button and choose Save Link As. Now you can hack it to work with your version if necessary and then drag the updated XPI into your Add-ons box under the Extensions section.

share|improve this answer
add comment

There is now a better way to do this: Use the Add-on Compatibility Reporter, an extension developed by Mozilla themselves. In addition to allowing any extension to run, it lets you give feedback about whether it works or not.

Add-on Compatibility Reporter

Help Mozilla make sure your favorite add-ons get updated for upcoming Firefox releases by using this extension to report whether they still work or are having some issues with alpha and beta releases.

share|improve this answer
add comment

The very useful add-on MR Tech Toolkit :

Provides the tools needed to install and manage extensions and themes locally and tons of other features.

This extension provides multi-extension installation support, hacking capabilities to the Extension/Theme manager windows, features to find and troubleshoot Extensions/Themes Build, GUID and Profile information.

image

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.