Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This morning I started my Google Chrome browser as I do every day. The text size was suddenly bigger than normal, on all sites. I did not change any setting anywhere.

If I set the zoom to 90% it looks fine, but this breaks various things (e.g. Stack Exchange chat) so prefer to avoid it if possible.

Setting font size to Small in Chrome Settings also help, but it's too small.

I have uninstalled Chrome (deleting local data) and installed again, same thing. Tried beta channel as well, no change.

Windows 7 OS 64 bit, Display set to 125% from the very beginning. (Did not change this for years)

What could have caused this and how can it be solved?

This very question turns out to be a good example to demonstrate what I mean:

While the body itself is small (as I changed the font size in Settings), other things are still huge and not affected by the setting.

share|improve this question
    
@suspectus no, this change the Zoom level, not font size and I mentioned this in the post. –  Shadow Wizard Aug 27 '14 at 8:04
    
Do you use Chrome stable? I think the latest stage got DirectWrite support. Might be related to that –  Sathya Aug 27 '14 at 8:16
    
@Sathya yes I originally used stable but tried installing Beta - did not have any effect, so uninstalled and installed stable again. –  Shadow Wizard Aug 27 '14 at 8:17
    
the beta already has DirectWrite support - as does the stable, IIRC. Can you head over to chrome://flags/ and see if there's an option to disable DirectWrite? –  Sathya Aug 27 '14 at 8:19
    
@Sathya thanks there is such an option indeed and I enabled it. No change. (restarted Chrome, do I have to restart Windows as well?) –  Shadow Wizard Aug 27 '14 at 8:21

3 Answers 3

up vote 27 down vote accepted

This reddit thread seems to suggest that this is a Chrome bug. For now, a temporary workaround is to force HiDPI support in Chrome

To do this:

  1. Right click on the Chrome link
  2. Choose Properties and then add /high-dpi-support=1 /force-device-scale-factor=1 to the existing Link to your path to chrome.exe.
  3. Be sure to close all running chrome processes from the taskbar before re-running the shortcut with the flags

enter image description here

share|improve this answer
9  
Also, be sure to close all running chrome processes from the taskbar before re-running the shortcut with the flags –  OpherV Aug 28 '14 at 13:35
    
So, are there any additional options for fixing this problem? Changing the shortcut settings is a rather limited fix, since it will only affect Chrome launched through that shortcut. Chrome launched through different shortcuts or in any other way will still be broken. Is there a registry-based or env variable-based fix that would apply that scale factor setting globally? –  AnT Oct 10 '14 at 13:53
    
... After further testing, no. /force-device-scale-factor=1 setting breaks rendering of thin visual elements on some web sites. For example, thin lines separating topics on e90post.com/forums/forumdisplay.php?f=2 disappear completely when this setting is enabled. The lines are supposed to be there. –  AnT Oct 10 '14 at 14:36

You can also fix this issue by turning off the "Disable DirectWrite" advanced setting in Chrome.

i.e. Disable the setting that is called "Disable DirectWrite". Do not Enable this setting.

Paste this into the Chrome address bar and turn off the setting:

  • chrome://flags/#disable-direct-write

When you are done, it should look like this:

enter image description here

Thanks to Ludwig on this bug report:

share|improve this answer

Use Chrome Canary (Version 39.0.2144.2 canary (64-bit)). The font is as small as before there.

share|improve this answer
2  
No thanks, I don't want to switch browser, I like Chrome as it is. (if the bug would be permanent then I would consider it, but otherwise really no reason to) –  Shadow Wizard Sep 3 '14 at 14:14
    
This is just a terrible hack for an answer –  Dave Dec 2 '14 at 10:55

protected by Community Aug 29 '14 at 12:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.