Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

New graphics card: Geforce 9500 GT 1 GB. http://www.gainward.com/main/vgapro.php?id=125

It works just fine under Windows XP, 1920x1080 with 3D, stable under load.

But when I boot Linux, I get a black screen after the boot & load sequence. This happens with several tastes of linux. Example:

  • insert Ubuntu Live CD, boot Ubuntu from CD (graphics and all)
  • select "boot Ubuntu"
  • get Kernel boot messages (decompressing elf etc)
  • get black screen. Monitor says there is a proper signal. Doesnt matter if I boot into X or single user mode.
  • try ctrl-Fx, ctrl-alt-backspace etc. No response.
  • press ctrl-alt-delete
  • get Ubuntu shutdown screen (remove cd)

The same goes for previous Debian installations, or a new debian installation. As soon as linux switches from legacy VGA, the screen goes black. Virtualbox with Linux works just fine in Windows, of course.

The card itself seems to be fine, though, in fact I am writing this on the same system, just with windows.

Has anyone else seen something similar? Any ideas on getting Debian to show the screen?

Problem is: I dont get to see any logon screen, just the boot messages. I do know how to install the nvidia drivers, and they were active with the old graphics card (old GeForce 6600). Problem is I dont get a chance to log on at all, because not even the shell does show.

share|improve this question
    
That's Alt-SysReq-k for Ubuntu. Don't blame me, I hate it too. –  kmarsh Jan 7 '10 at 21:20
    
BTW having the same problem with both a 6600GT and a 7800GS AGP on Kubuntu 9.04. It's not the monitor because I've tried two. I think it is the nvidia proprietary drivers. If AMD/ATi is stepping up their game as much as Phoronix says they are, they might be my next video card. –  kmarsh Jan 7 '10 at 21:21
    
Didnt work on this for a while - now getting behind it: the builtin VESA drivers refuse to show a pic on the card. –  Posipiet Jan 8 '10 at 17:49
add comment

2 Answers

Video driver problems aren't uncommon in Linux, especially with high end cards.

Sounds like X is not happy with your card. Boot to the command line, then go to /etc/x11/xorg.conf and check the settings that are configured with the card. Chances are the resolution or refresh rate or something similar is out of the cards supported settings.

Here's a link to the xorg.conf man page...You're going to be looking under the "Device" section.

Here is a link to someone with similar problems on the Ubuntu forums. There are some sample config files in the thread.

Here is the basic Ubuntu How-To-Install-Drivers-For-Nvidia-Cards wiki. Could be you just don't have the driver right. Were you using an ATI card before? ATI doesn't play as well with Linux as NVidia does.

@Edit

If you can't even get the command line, try booting into "Failsafe Graphics." By saying, "Boot to the command line" I'm saying single user mode...If you let X start, it won't let you do anything.

share|improve this answer
    
command line screen is also black.... –  Posipiet Dec 8 '09 at 19:51
add comment

Try Fedora 12. Ubuntu is still using the really poor nv driver by default, Fedora uses the much newer and improved nouveau driver which is more likely to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.