Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I type the command "telnet" in Windows XP command prompt, I get the output as:

'Telnet' is not recognized as an internal or external command, operable program or batch file

I've already enabled the telnet client by clicking on Start option from 'Administrative Tools\Component Services\Services (local)'.

Why then is it not working?

share|improve this question

6 Answers 6

up vote 2 down vote accepted

If you type telnet on the command prompt and get this error I'm convinced that you're XP has been explicitly changed in this way. The option you enabled is the telnet SERVICE (Which is a BAD idea!). That is opposite of what you tried in the first place which is the telnet CLIENT.

share|improve this answer

As far as I recall telnet client (or server) is not installed by default, for security reasons. You have to install it yourself by starting "Add/Remove Programs" in the control panel.

share|improve this answer
1  
Telnet client is on by default in XP. It was taken out and only included as an optional extra in Vista / 7. I believe (but not 100% sure off by heart) that Telnet Server is included in Windows XP and up (maybe just Professional / Business editions) but set to disabled by default. –  William Hilsum Dec 8 '09 at 20:22
    
That's for Vista++ –  John T Dec 8 '09 at 20:22
    
Sorry, it was a century ago I used XP. ;) –  TFM Dec 8 '09 at 21:46

That's odd, XP should have it included. If you have a Windows XP CD lying around, pop it in and run this from the run box (Win + R):

sfc /scannow

This will start the Windows File Protection service and begin to scan all protected files and verify them. It will replacing any files which are missing or have problems.

share|improve this answer
  1. Right-click on the My Computer icon
  2. Go into Properties
  3. Go into Advanced tab
  4. Click on Environment variables.
  5. Find out the PATH variable in "System Variables"
  6. Double-click on it
  7. Edit the path at the end of the line to add C:\windows\system32

I am assuming you have Windows installed on the C: drive.

share|improve this answer

Doing what you said enables "Telnet Server" on your machine. It allows anyone with telnet to connect in to your machine via it's IP and get a "command prompt" like interface.

You want telnet client. That is a weird error you are getting - it is possible that your path / session variables have been lost.

Try typing this (in this order, if you have default locations):

c:
cd \ 
cd windows
cd system32
telnet

If you still get the error, go to another machine with it and copy, or alternatively, look at using PUTTY which is a free multi protocol program that supports Telnet.

share|improve this answer

The telnet client is installed with XP at C:\WINDOWS\system32\telnet.exe.

Check that you have this executable file, and if it was deleted by any chance, copy it from another XP computer.

Please note that you also need these files:
C:\WINDOWS\Help\telnet.hlp
C:\WINDOWS\Help\telnet.chm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.