Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the same problem on two of my Linux boxes (xubuntu, debian). When I use the "date" command in bash, the results are displayed in Japanese language.

2014年 9月 2日 火曜日 02:48:48 UTC

I am located in Japan and under the Japanese time zone, but I would like my working environment, including the output of the date command, to be in English.

How can I do that?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is not determined by the timezone, but rather by locale settings.

I'm not sure if Xfce has an UI for specifying system locale in a detailed enough manner. But at the low level, there are several environment variables, which you can see by typing locale. The main one is $LANG, which sets the general system locale, and for specific areas there are separate $LC_* variables – e.g. $LC_MESSAGES for the translations used by programs, and $LC_TIME for the date/time formats.

If you simply want everything to be in English, then the configuration is simple – select an English locale in your Xfce settings. (Typically "United States" aka en_US.UTF-8, though I use en_DK.UTF-8 for LC_TIME myself, as it gives ISO 8601 dates.) This will not affect time zones at all.

If you want specific settings for English and others for Japanese, you might have to manually "export" the specific variables in your ~/.profile or /etc/default/locale or ... wherever Ubuntu puts it. For example:

LANG="en_US.utf-8"
LC_COLLATE="lt_LT.utf-8"
LC_TIME="en_DK.utf-8"

(In ~/.profile, using export LANG=... is necessary.)


Another thing to note that if you switch between two *.utf-8 locales, it will not affect the character sets either – any UTF-8 locale still uses Unicode, so Japanese text will still work with en_US.utf-8. (Not to be confused with the old en_US which uses legacy ISO 8859.)

share|improve this answer
    
thank you grawity, yes I simply want everything to be in English. How can I change my "Xfce settings"? I.e. I don't know in which file I can change that. –  gojira Sep 2 at 7:13
1  
I checked and it doesn't look like Xfce even has settings for this, so try /etc/default/locale. –  grawity Sep 2 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.