Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem. My Centos 5 box died and had to have the motherboard replaced. I got it back up and running and now when I try to boot I get a "No Volumes Found" message after the linux image is unpacked.

I've downloaded and burned a copy of the Centos 5.4 LiveCD and was able to verify that the harddrive is not damaged. All the files are there, including the LVMs, however Linux won't mount the LVMs when it boots and consequently it fails with a kernel panic.

I should probably mention that during the time it took to get the new mother board, I've tried to take the hard drive and plug it into a Windows box but without any success (I quickly realized that windows won't recognize any of the linux filesystems)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If the drive controller on the new motherboard is setup to be native SATA, see if it can pretend to be a PATA controller (many can).

It could be that your CentOS setup is configured to only scan for physical volumes for LVM on /dev/hd* and not /dev/sd* - if that is the case then the drive appearing as /dev/sda or similar will make it invisible to the LVM setup in your initrd (but the boot CD can see it as it is setup to scan both hd* and sd*).

Not all chipsets/BIOSes support making the drive controller look like a plain old PATA controller, but many do (and many default to doing so, which I suspect to be the case with your old motherboard). Failing that, all is not lost: you should be able to build a new initrd using the live CD to make it work, though that will be quite a bit more complicated.

share|improve this answer
    
@David, that makes a lot of sense. The new MB is the same make/model as the old one so I'll check in the BIOS the settings for SATA emulation –  Miky Dinescu Dec 8 '09 at 22:14
    
You were right, although with a twist: the CentOS setup was scanning for sd* devices and the new MS's BIOS was configuring SATA for compatibility mode. Changed it over to native and things are back to normal. Thanks for your help! –  Miky Dinescu Dec 8 '09 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.