Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Usually in Windows, if videos or other media is upscaled from a certain resolution to a higher resolution (e.g. "monitor size"), a bilinear filtering algorithm or similar is used, such that the upscaled material doesn't look blocky.

On my system however, the used interpolation algorithm changed from 'bilinear' to 'nearest neighbor' at some point, with the effect that upscaled videos (e.g. viewed in MPC or WMP, and also Skype video streams) and games (e.g. from PopCap) appear rather blocky. Not sure what the common factor between those is, could be DirectShow(?).

I am not aware of having changed any setting that could have affected this state, in fact I am not even aware such a setting exists. I'm guesing that some installed software must have changed something on my computer.

My computer is running Windows 7, but I had already experienced the same effect on an XP machine some while ago, where it changed back again to the more pleasing bilinear interpolation after a while, as magically as the first time. What could be wrong with this installation, and how can I change this upscaling interpolation behavior?

share|improve this question
    
If your video card has any settings, I would glance through them. –  zildjohn01 Jan 9 '10 at 4:20
    
Did you ever find an answer? I saw this on a machine in videos played by VLC; one of the renderers it offered fixed the "nearest neighbour" problem but caused others. The problem disappeared with a video card upgrade. I now have this on another machine and nothing helps. –  romkyns May 26 '10 at 22:19

2 Answers 2

I dont think there is a universal setting on which you can configure directshow. DirectShow is an API which is used by various media players. Each player would set the configurations when creating the directshow graph. This means that each application stores its configurations in its own location.

Dig around in your media player softwares. There might be quality options somewhere. (maybe your graphics card drivers have a utility that configures it).

share|improve this answer
    
Well, I am not sure if it has anything to do with DirectShow, that was just a wild guess. It's not down to a quality setting in a set of programs - it is definitely some systemwide state that changed. There's no setting in the graphics driver that I'm aware of (or anywhere else in the system, and I've done some digging). –  user20673 Dec 9 '09 at 0:03

You could try installing the ffdshow codecs and tweaking the methods/etc. from the config GUI.

Example screen of GUI for ffdshow video config

This would give you the added benefit of more/different codec support, of course.
Tread carefully if you tweak things, though, and do your research before changing the settings, as you can seriously mess things up.

share|improve this answer
    
I am already using ffdshow, however that is a workaround only for video players that support it, not for other media players or the games I mentioned. Besides, I'd really like to know the nature of the problem. I still have no idea why upscaling doesn't work properly. However, I don't seem to be the only one with that issue. This forum post: forums.steampowered.com/forums/showthread.php?t=855227 describes exactly the effect I am experiencing (w.r.t some games I also have installed). I guess the affected posters there didn't notice that this also extends to video files, streams, etc. –  user20673 Dec 12 '09 at 15:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.