Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was wondering if anyone else was having this experiance and whether they managed to fix it.

I have Windows 7 on my notebook and when I start up it can take up to 5 minutes to connect to my network. Either wireless or cable makes no difference.

It used to be seconds but after an update from MS it slowed.

Once it's connected, I can yank the plug and insert it again and it connects immediately. It's just on initial start up, or out of sleep mode, that the huge delay exists.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Remove the connection from the Homegroup in the Network and Sharing Centre. Reboot.

If this doesn't fix it, try this: uninstall the wireless network adapter from the device manager, restart the computer, windows will pick it up again.

share|improve this answer
    
Thanks @Molly, will try that tonight. –  griegs Dec 9 '09 at 2:56
    
That worked thank you. I wonder why it happened tho. –  griegs Dec 9 '09 at 8:08
add comment

you can try to make a static ip address for your laptop. i keep mine on static because it doesn't have to talk to the router to get its ip. therefor the connection is instant.

here

there is a website that can help you configuar your static ip. remember to write down all of your connections ip's and DNS so you can put in the correct information that your ISP has provided.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.