Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A prime example of the above is logging into SO/SF/MSO/SU. I use myopenid and have an SSL Client Certificate, but each time I start FF I have to login. This happens for my Yahoo, GMail, etc as well.

I'm not clearing my settings on close for FF, so I'm not sure where to go from here.

Any ideas?

share|improve this question
    
Have you disabled cookies? –  Alex Rozanski Jul 18 '09 at 17:00
    
@Perspx: Cookies are on (and they smell gooood!) –  JFV Jul 18 '09 at 17:57

5 Answers 5

up vote 2 down vote accepted

I had exactly the same problem recently, I'm not sure what caused it, but I found uninstalling and then reinstalling Firefox fixed the problem. Don't forget to backup your bookmarks beforehand.

For what it's worth, this was with Firefox 3 (3.0, I think) on Windows Vista 64.

(obligatory)

share|improve this answer
    
Love the link! I'll give it a shot and let you know... –  JFV Jul 18 '09 at 18:19
    
Whatever it was, a full uninstall and reinstall fixed it up! Thanks! Yes, I know I should have done it before asking, but I was hoping that I wouldn't have to re-setup all the add-on's I had... :-\ –  JFV Jul 18 '09 at 18:37

Are you flushing your cookies at exit? check the firefox privacy configurations.
This would also happen if you do not have rights to save in your windows login or
If you have roaming profiles (not usually likely) that are not sync'ed properly.

share|improve this answer
    
I've checked and no. Thanks for reminding me though, you never know what you might forget! –  JFV Jul 18 '09 at 17:02

You could have a third-party "Internet security" program installed that deletes all your cookies for you -- hard to say without seeing your computer. Your issue seems to be cookie related.

share|improve this answer
    
I only have McAfee Corp installed as Anti-Virus, but have Ad-Aware AE and SpyBot Search & Destroy installed for adware/malware/spyware. None of these have automatically cleared out the cookies and I haven't done it manually. Thanks for the tip. –  JFV Jul 18 '09 at 18:18

The original issue was solved but in case someone else has similar problems: Check privacy.clearOnShutdown.* settings in about:config.

share|improve this answer

I fixed a similar problem on a family member's computer recently; deleting cookies.sqlite from Firefox's profile directory fixed the problem. (Oddly, clearing cookies from within the Firefox UI didn't fix it -- the DB file itself had to be removed).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.