Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run continously run Serious Samurize to show graphs of CPU, disk and network usage. Occasionally I see that my E: drive (a hard disk with no system files on it, only data) is thrashing away when it shouldn't be (showing around 50% bandwidth usage on the graph). Using process explorer I see that the culprit is CcmExec, a standard Windows component. It looks like it is reading every file on the disk.

So, my question, why is CcmExec doing this to me? And, how do I stop it? Suspending CcmExec from process explorer works well, but I have to remember to do this every time I start my machine. I suspect there's a better way to tell it to keep its dirty fingers of my E drive.

I'm running Windows XP on a company network.

share|improve this question
    
Disabling "SMS Agent" in Windows' Services seemed to do the trick. –  Andrew Bainbridge Jul 13 '11 at 13:50
add comment

2 Answers

up vote 2 down vote accepted

CcmExec is part of the Systems Management Server from Microsoft. There are a couple of articles on MSDN blogs that address this issue. You should be able to stop this from happening by stopping the "SMS Agent Host" service.

Jonathan Hardwick offers three ways of turning off the service:

  • From the command line: sc stop ccmexec and sc start ccmexec (where sc is c:\windows\system32\sc.exe)
  • From the GUI #1: open the services list, right-click on the SMS Agent Host service, and select Stop or Start.
  • From the GUI #2: having typed sc stop ccmexec and sc start ccmexec into Start>Run, use the drop-down history menu at the end of the Run box to re-run them whenever you want to.
share|improve this answer
1  
This is more of a workaround than a solution. –  Christothes Jul 11 '11 at 17:49
    
This is -not- a solution. Doing this will disable updates. It's a temporary workaround at best. Please unmark as answer so that the community can look into this closer. –  Wouter Mar 3 at 9:57
    
Christothes's answer fixed the issue... completely or partly. Not sure yet... –  Wouter Mar 3 at 10:10
add comment

In some cases this can be due to some corruption in WMI. Upon exploring the threads causing the CPU usage in Process Explorer, you may find many of them have WMI somewhere in the stack.

Try running the following command from an elevated command prompt.

winmgmt /resetrepository

You may get the following error:

  • WMI repository reset failed
  • Error code: 0x8007041B
  • Facility: Win32
  • Description: stop control has been sent to a service that other running services are dependent on.

If so try running the winmgmt command again after killing the ccmexec.exe process.

share|improve this answer
    
WmiPrvSE was eating 350MB of RAM on my system.. The logs fingered ccmexec. Stop-reset-start and it's looking better now. –  John Fouhy Apr 20 '12 at 2:26
    
This looks closer to a solution. Doing this, and a reboot, stopped ccmexec.exe from endlessly searching the hard drive. After the reboot I'm still seeing WmiPrvSE and svchost.exe causing a disk queue, and using CPU. After a few minutes everything dropped to 0. I'll post if i find out more... –  Wouter Mar 3 at 10:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.