Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm looking to throttle my cpu through the ACPI. I've read up on it, but I keep receiving permission denied statements. I have 8 available throttling states. Here are the outcomes of my atttempts:

evan@evan-laptop:/proc/acpi/processor/CPU0$ echo 3 > /proc/acpi/processor/CPU0/throttling

bash: /proc/acpi/processor/CPU0/throttling: Permission denied

evan@evan-laptop:/proc/acpi/processor/CPU0$ sudo echo 3 > /proc/acpi/processor/CPU0/throttling

bash: /proc/acpi/processor/CPU0/throttling: Permission denied

EDIT: For reference, I am running Ubuntu Karmic with Intel Core Duo T2500 with ACPI enabled

share|improve this question
    
If you want to control it from terminal then also add info about your computer. It could be useful. uname -a, cat /proc/cpuinfo –  egon Dec 9 '09 at 20:57

1 Answer 1

up vote 1 down vote accepted

First do

cat /proc/acpi/processor/CPU0/throttling

Then use any of those states:

echo T4 > /proc/acpi/processor/CPU0/throttling

Also you can look in cat info if throttling is enabled.

share|improve this answer
    
Nope, not weird just more specific needs... –  egon Dec 9 '09 at 21:18
    
hmmm, thanks for looking into this. I had tried this too and tried again, but I get the same Permission Denied line. This is my first computer with Linux, so I'll search around for a little bit. –  Evan Dec 9 '09 at 21:27
    
egon, I found out that the sudo only applies to the echo rather than the whole statement. if I just run it as a script from sudo or su to root (is there root on Ubuntu?) The problem is solved. It was definitely my newness to Linux that caused this particular problem –  Evan Dec 10 '09 at 1:03
    
totally forgot about that... I was logged in as root... so yeah... :D –  egon Dec 10 '09 at 15:54
    
> cannot be used with sudo, tee can. just do echo T4 | sudo tee /proc/acpi/processor/CPU0/throttling –  Steve Schnepp Aug 21 '10 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.