Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using ThunderBird 3 on Windows 7. When I get a mail with a link, I usually click it, if I know what it's about.

Sadly, Thunderbird switches to Firefox which is opening the new tab. I'm active on several forums and get several of these messages per day. I don't want to click a link, be forced into firefox, go back to thunderbird, click a link, be forced into Firefox, etc...

Is there an option to disable this? If not, I can see myself quitting Thunderbird altogheter and simply using web-based email checking instead of using an app.

share|improve this question
    
So you want the links to not work? Or do you want to fire another browser? –  random Dec 10 '09 at 3:54
    
No, what I want is to click all the links, and firefox opens them just as normal. What I don't want is being switched to firefox everytime I click a link. I want to click them all, all why staying in Thunderbird, and then go to Firefox when I feel like it. –  KdgDev Dec 10 '09 at 9:43
    
So open all the links you click on the background, but not change focus, not switch out the windows. –  random Dec 10 '09 at 11:33
    
@Eight Days: this is what I want, but it seems that it is not possible to set this in the settings. –  KdgDev Dec 10 '09 at 17:10
add comment

3 Answers

up vote 3 down vote accepted

I'd recommend going with the ThunderBrowse extension. Lets you view links in the message pane.

Edit: Since you want the links to open in the background in a firefox window, try settingbrowser.tabs.loadDivertedInBackground totrue in Firefox's about:config. This should let you open any links sent from programs without bringing firefox to the front.

share|improve this answer
    
Sadly, I want them to open in Firefox, which this addon does not seem to offeR. –  KdgDev Dec 11 '09 at 1:10
    
I agree with mattikus: this is a feature of Firefox, not Thunderbird. Setting browser.tabs.loadDivertedInBackground fixes this (but unfortunately it also does not focus the new tab) –  Palmin Jan 5 '10 at 21:17
add comment

I had the same problem and solved it by installing add-on "Tab Mix Plus" to Firefox. Tab Mix Plus allows you to control if you want to change focus (when to switch to a window/app) when you click on links/bookmarks/etc.

After installation of add-on, open Tab Mix Plus options in Tools. Click on Events tab. Click on Tab Focus tab. Uncheck all boxes under "Focus/Select tabs that open from:" Click Close.

This should solve your problem. Tab Mix Plus does not work with the latest Firebox 4 beta, however.

Cheers.

share|improve this answer
    
There's one answer above this one. That did it for me. –  KdgDev Jan 2 '11 at 17:56
add comment

THIS is the more permanent solution I think you're looking for - worked well for me, although you may have to repeat the exercise if you ever return Firefox to its default settings

First, type (or copy and paste) "about:config" (minus quotes) into the Firefox address bar and hit enter.

In the Filter bar, type (or copy and paste) "browser.tabs.loadDivertedInBackground" minus the quotes.

By default, the value of this entry is false. To change it, double click the entry and it will toggle so that the value reads true. Restart Firefox and you're done.

share|improve this answer
1  
In the future, please include all relevant steps here on the site, thanks. –  slhck Mar 19 '12 at 9:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.