Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can log in once, use the remote machine ok, and disconnect or logout, but remote desktop login hangs if I try to log in again. The remote computer login process completely hangs. I can't go to it's console to get in, I either get a message there about processing a login or just a blank start screen. I have to hit reset on the box to reboot and get back in. I am using the exact logout or disconnect instructions in the help for remote desktop connection.

Local machine is xp sp 3, with remote desktop connnection client 6.0.6001.18000. I never had this problem with earlier version. (Is there any way to get the old version of the client back? I never should have installed this update. I can find no way to uninstall remote desktop connection, it's one of those built in features.)

Remote can be either vista32 or win7-64 in my case. I thought I had this problem fixed a few months ago, but it's back now. No one has come up with a solution, I think it's a bug in microsoft software. It should never hang the remote machine regardless of how I misuse it. I've worked this problem through microsoft forums and newsgroups to no avail.

Please don't respond if you are just going to recommend another type of software for connections.

share|improve this question

Have you tried updating the remote machines' RDP software? It sounds like a problem on their end, not the local machine. Make sure both local and remote machines have their remote desktop software updated.

share|improve this answer
Kind of ironic since updating the xp machine's remote desktop connection client got me into this situation. Everything is unfortunately up to date. – P a u l Dec 10 '09 at 15:49
up vote 0 down vote accepted

I found that the problem is in recent versions of zone alarm for windows 7. There is no eta for a fix but they told me they are working on it.

share|improve this answer

Working with Windows RDS Server reverse remoting into a single workstation, could log in once in an RDP session on the workstation, log out and next time it would hang with the eternal circulating wedding band or a black screen.

Logging in as administrator on the workstation and using command line qwinsta shows the hung session for the user, rebooting the station or resetting the dead session will allow RDS login.

Went into network adapter properties on the workstation, found "Large Send Offload" and disabled it on the workstation. The disconnect hang departed.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .