Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Terminal my bash prompt is

unknown-00-26-bb-16-08-a0:~ simon$

When I switch Web Sharing on, I am presented with the following URL as the location of the site served from my machine:

http://unknown-00-26-bb-16-08-a0.home/~simon/

Can anyone help me identify why this is happening?

I am running OS X 10.6 on a MacBook Pro.

Many thanks

share|improve this question
    
The name is probably being included in your DHCP server's response. You might look there (probably your Internet router) to see if there is an option to assign a name for your MAC address. –  Chris Johnsen Dec 10 '09 at 22:27
add comment

1 Answer

up vote 2 down vote accepted

You can change/check your local hostname by going to System Preferences and opening the Sharing Preference Pane. Mac OS X uses the local hostname over the host name. (echo $HOSTNAME will show the local hostname)

You'll want to click the Edit... button near the top of the window under where it says your Computer Name. You can then set your local hostname. The other method is via the command line:

sudo scutil --set LocalHostName simon
share|improve this answer
    
Doesn't work for me. My computer's hostname is Steves-MacBook-Air.local, but appears in DHCP as unknown1040f388c48c. –  Steve Taylor Jun 16 '12 at 5:00
    
As it turns out, I broke the 16 character limit. When I changed the hostname to Steves-Mac, it worked. –  Steve Taylor Jun 16 '12 at 5:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.