Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've found there are couple of problems might be related how my FAT32 partition was mounted.

I hope you can help me to solve the problem. I also included the command I used to help others when they find this post, sorry to those might feel I should use less space.

I've the following file structures on my disk

dean@notebook:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x08860886

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        5737    45978624    7  HPFS/NTFS
/dev/sda3            5738       10600    39062047+  83  Linux
/dev/sda4           10601       19457    71143852+   5  Extended
/dev/sda5           10601       11208     4883728+  82  Linux swap / Solaris
/dev/sda6           11209       15033    30720000    b  W95 FAT32
/dev/sda7           15033       19457    35537920    7  HPFS/NTFS

In the etc/fstab I've got

UUID=91c57a65-dc53-476b-b219-28dac3682d31  /             ext4     defaults                           0  1  
UUID=BEA2A8AFA2A86D99                      /media/NTFS   ntfs-3g  quiet,defaults,locale=en_US.utf8,umask=0                           0  0  
UUID=0C0C-9BB3                             /media/FAT32  vfat     user,auto,utf8,fmask=0111,dmask=0000,uid=1000                           0  0  
/dev/sda5                                  swap          swap     sw                                 0  0  
/dev/sda1                                  /media/sda1   ntfs     nls=iso8859-1,ro,noauto,umask=000  0  0  
/dev/sda2                                  /media/sda2   ntfs     nls=iso8859-1,ro,noauto,umask=000  0  0  

I checked my id using id and I've got

dean@notebook:~$ id
uid=1000(dean) gid=1000(dean) groups=4(adm),20(dialout),24(cdrom),46(plugdev),103(fuse),104(lpadmin),115(admin),120(sambashare),1000(dean)

I don't know why with these settings I still have problem of using svn like in this one

Thank you for your help!

share|improve this question

2 Answers 2

Check the mount options for fat (and vfat). I believe you're looking for the check option.

check=value

Three different levels of pickyness can be chosen:

r[elaxed] : Upper and lower case are accepted and equivalent, long name parts are truncated (e.g.verylongname.foobar becomes verylong.foo), leading and embedded spaces are accepted in each name part (name and extension).

Either relaxed or strict may solve the issue for you, depending upon how the svn will interpret the resulting case of the files.

share|improve this answer

You can try these options if you have the old kernel:

posix
shortname=mixed

share|improve this answer
    
What do these options do? –  Simon Sheehan Apr 2 '12 at 11:45
    
they are deprecated as for kernel v3, but back then thay allowed files be different if name capitalisation differs. –  ZaB Apr 3 '12 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.