Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got bored and decided to change my folder icon from the boring yellow default. Somewhere in my experiments, I discovered that anytime I open a folder it opens in a "search" window.

This happened because when I go to the "(file folder)" type, the only option in there is "find" that is not supposed to be the default; upon saving this form XP tries to do me a favour and sets this as the new default.

Now whenever I try to click a folder it opens the search window. How do I fix this?

share|improve this question

3 Answers 3

The quickest solution I could find (after trying all the pre-written registry fix files) was to find the item titled "Directory" (not "(file folder)", why on earth are they named differently!?!) ad set the "(Default)" option within it's /shell/ key to something that doesn't exist; explorer then defaults to whatever it was doing before.

Ahhh... 2 hours after what I thought was a quick 2 minute icon change. Joys of XP :-D

share|improve this answer

I had a similar issue once before. I'm pretty sure the issue I had was whenever I tried to open a folder, it would instead give me a new console window with the current directory set to the folder I was in. I think I ended up fixing it by going into a virtual machine, making a copy of the registry keys in question there and then applying it on my main machine.

Directory and File Folder. Those are the (abridged) registry keys for those two; hopefully you'll be able to check them to make sure they do what they should and then apply them (Try the file folder one first) and hope for the best. Copy them to their own files and rename them directory.reg and filefolder.reg respectively.

Run them, and say yes to the merge question. That should fix your issue; if it doesn't, try opening the registry editor with Start->Run->regedit.exe, then navigate to HKEY_CLASSES_ROOT. Make a backup of both Directory and Folder, then delete Folder and apply the script I linked. Do the same for Directory.

If that still doesn't fix it, I'm not sure what else you could try. Reinstalling windows is a thought, I've done that to fix some particularly difficult issues. Good luck, and be careful! The registry editor is a dangerous tool.

share|improve this answer

Use the following fix from Doug Knox' website:

Restore default associations for File Folders

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.