Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes when I open a document and view the Document Map, I discover that Word 2007 SP2 has completely destroyed my outline by assigning seemingly random paragraphs an Outline Level of 1. I then have to manually set 50-100 paragraphs to "Body Text" and hope it doesn't happen again (which it will).

My guess is that it happened somehow during my previous editing session, but I've never seen it change while editing the document. I think it might have something to do with closing the application with the Document Map open.

I tried searching to see if this is a known bug but couldn't find a solution.

Found an article describing the behavior but no mention of a patch by MS. http://www.bitwisemag.com/2/Microsoft-Word-Expletive-Deleted

share|improve this question
    
This appears to be fixed in Word 2010 (finally!) –  Greg Nov 1 '10 at 17:42

4 Answers 4

up vote 2 down vote accepted

From the article you quoted, from a comment by Stuart towards the end:

I’ve had the same problem in Word 2002 (XP). In my observations below, DM = document map and TOC = table of contents.

Tips to prevent or deal with the problem

  • Exclude the TOC until you’re ready to either print the document or convert to PDF. The TOC and the DM seem to interact to create instability.
  • Always close the DM pane before closing your file or Word. The DM is more stable when a document is opened with the DM pane is closed.
  • Always open documents with DM pane closed. If you’re uncertain, start Word first, close the pane, then open your document.
  • You can tell that your DM is being scrambled if Word shows the “Word is formatting the document…” status bar while the file is opening.
  • Always check your DM when you first open the file.
  • The only time I’ve noticed a DM become scrambled is on open. This doesn’t mean there aren’t other times it’ll become scrambled. For example, I’d be cautious by closing the DM pane when generating a TOC, or printing or converting documents to PDF, especially if they contain a TOC.
  • I don’t know what makes a file susceptible to scrambling on open in the first place.
  • As soon as you notice your DM is scrambled, close your document without saving.
  • Saving the file with a scrambled DM will permanently scramble both the DM and the TOC. It’s actually the heading level tags that get scrambled.
  • Use Word’s auto-backup feature: Tools -> Options; Save tab; check “Always create backup copy.” Lets you roll back one save.
  • Create and keep frequent backups of your own, even several in a day if you’re being particularly productive: time is precious; disk space is cheap.
  • If you don’t need the really rapid navigation offered by the DM, try using Outline view instead. According to what I’ve read, it’s not prone to scrambling.
  • Additional observations: Merging an older, unscrambled copy with a scrambled copy passes the scrambling on to the good copy, no matter which direction you merge (good into bad, or bad into good), or which document’s formatting you opt to retain. I haven’t found any way to repair/recover a scrambled and saved file, but I haven’t tried any commercial recovery products.

To remedy

If your DM becomes scrambled and you haven’t saved your document:

  1. Close the document and Word without saving
  2. Open Word
  3. Close the DM pane
  4. Open your file

From another comment by by Jan Zambor :

To repair a scrambled doc:
1. select entire doc (Ctrl+A)
2. go to Paragraph windows
3. set Outline level to "Body Text" (headings will NOT be set to body text, you should end up with the correct doc)

share|improve this answer
    
The Select entire doc (Ctrl+A) and setting Outline level to Body Text worked for me. In addition, I had to close the DM pane before saving otherwise the changes were not saved when I reopened the word document. As to what triggered this, I was editing the caption formatting just before word went crazy and started promoting random text to Level 1 outline. Thanks harrymc +1000, I was supposed to submit the 60+ page report in a few hours time and this happened. Saved! –  Joel May 17 '13 at 5:55

The CTRL+A, set Outline Level to "Body Text" approach works if and only if you close the document map then save. When you re-open the document it should be clean.

share|improve this answer

See my answer on the same topic: Document Map in MS Word 2007 going bonkers

share|improve this answer

I found the following macro from this post. It solved the issue for me.

Sub ReSetOutline()

    Dim myPara As Paragraph
    For Each myPara In ActiveDocument.Paragraphs
        myPara.OutlineLevel = myPara.style.ParagraphFormat.OutlineLevel
    Next myPara

End Sub
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.