Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to copy and paste lines of code to the linux terminal. However, I've noticed that when the copied text is too long (let's say, 60 or more lines), it gets trimmed and altered in an apparently random way (e.g. some characters missing).

I found the same problem in Ubuntu Karmic Koala, Fedora 10 and Ubuntu Jaunty Jackalope.

Any clue why this happens and if I can increase the size of safely copy/paste-able text?

share|improve this question

migrated from stackoverflow.com Dec 11 '09 at 21:30

This question came from our site for professional and enthusiast programmers.

    
Try a different terminal? Is this the terminal launched from the desktop on the machine itself, or are you connecting remotely? Does the clipboard limit behave the same in the terminal, in other apps, or just your ide/editor within that terminal? –  hometoast Dec 11 '09 at 16:57
2  
Tell us what terminal you are using. I have copied and pasted blocks of text thousands of lines long into gnome-terminal and putty with no issues. –  whatsisname Dec 11 '09 at 17:02

1 Answer 1

You could try messing with the preferences of the terminal. This 60 limit seems more a limit of the terminal, so there's should be an option the increase the terminal buffer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.