Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Windows XP, I try to connect to a wifi network, but get the following error "Windows Was Unable To Find A Certificate To Log You On To The Network". It never gives me the chance to enter the password.

This is a conventional wifi network, and I know it works, as my Linux box can connect to it just fine. Any ideas?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

See this article : Fix “Windows was unable to find a certificate to log you on to the network”.

The idea is to uncheck the Enable IEEE 802.1x authentication for this network for your wifi network in the Wireless Networks list.

share|improve this answer

The method in harrymc's answer didn't do it for me, and i've read somewhere it only works for WEP.

I had this problem with Win XP SP2

The options when right clicking the network connection and going to properties, included WPA and WPA-PSK but not WPA2 and WPA2-PSK (you will see the relevance of this soon). That is normal for SP2 to be missing those, though there is a patch. In this screen after clicking properties, you see what security settings are available e.g. WEP, WPA, e.t.c.
enter image description here

Connecting wirelessly to a router.

When I tried to connect to one router, it worked.

When I tried to connect to another, it didn't work and gave that message "Windows Was Unable To Find A Certificate To Log You On To The Network"

This is the second time i've seen that, and both times the following solution worked(suggested by my ISP Zen).

Download and Run the following patch KB917021
Update for Windows XP (KB917021)
http://www.microsoft.com/en-gb/download/details.aspx?id=24561

Requirements Windows XP Service Pack 2

The download is called WindowsXP-KB917021-v3-x86-ENU.exe

That then adds options of WPA2 and WPA2-PSK

Then even when I choose WPA it connected, but when I went back to the connections properties I see it had gone to WPA2. So, the message about not finding a certificate, was in my case, because the router was on WPA2 and Windows XP SP2 wasn't supporting that until I downloaded and ran that patch.

share|improve this answer
    
thanks a lot it works fine for new access points which support wpa2-psk2 –  RezaRahmati Dec 21 at 17:20
    
@RezaRahmati I guess you mean this solution makes it work fine for wpa2 –  barlop Dec 21 at 18:33
    
Yes I mean that –  RezaRahmati Dec 21 at 20:08
    
@RezaRahmati was that with SP2 or SP3 or other? –  barlop Dec 21 at 20:12
    
It was WinXP SP2 –  RezaRahmati Dec 22 at 5:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.