Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to install the files for supporting East Asian languages on Windows XP, which is usually possible through the regional and language options. However, the relevant checkbox (see below) is deactivated /grayed out on my machine.

Could this be because it's Windows XP Home on a netbook? I'm pretty sure I could activate it on other XP Home instances, and all the pages I've found on netbook-specific restrictions only talked about hardware limits.

Or could there be some other reasons, maybe something I can do to make it work?

enter image description here

share|improve this question
    
Sorry, have to ask: have you tried rebooting? –  hyperslug Dec 12 '09 at 12:31
    
How could that possibly help? My problem is not that configuration changes I've made aren't having an effect, the problem is that the checkbox I need to check is deactivated / grayed out. –  Michael Borgwardt Dec 12 '09 at 12:52

2 Answers 2

up vote 1 down vote accepted

If it is checked and grayed out, that means it is already installed.

All that is logically left to do is go to the Advanced tab and, under "Select a language to match the language version of the non-Unicode programs you want to use:", choose your language.

share|improve this answer
    
Except it's not checked and grayed out. –  Michael Borgwardt Dec 12 '09 at 14:02
    
Do you mean that it's unchecked and still grayed out? –  harrymc Dec 12 '09 at 15:00
2  
If yes, then next question is : Are you logged-in as administrator? –  harrymc Dec 12 '09 at 15:06
    
Finally got around to checking this out again and yeah, that was it (might be good to put that up in the answer). Lesson of the day: locking parts of a GUI without obvious reasons is shitty design. I'm beginning to lean towards the school of thought that says keep everything unlocked all the time and show an error when the user does something they're not allowed to and tell them why –  Michael Borgwardt Dec 22 '09 at 0:01
    
@Michael Borgwardt: That's one solution, but my idea would be a clear UI where the reason would be clearly displayed. For example if this was in a group box titled "Administrator permissions required". –  harrymc Dec 22 '09 at 6:59

I've found various sites (including this one from Microsoft) that explain the process and none of them mention that you have to have a specific version of XP to enable East Asian languages so it looks like your assumption that it should work on XP Home is correct.

So if, as you say the option is greyed out, it looks like you might have hit a restriction on your machine, what make/model is it?

This page on the Asus support forums has some conflicting information.

The first post indicates that they need SP3 installed - I'm assuming you've got that.

Another post implies the feature is only available with XP Pro - but that contradicts other information I've found.

The last post indicates that the files should be on the disks that came with the PC.

share|improve this answer
    
My problem is that I cannot even start the process of installing the files because the checkbox is disabled. The model is an Asus Eee PC 904HD. –  Michael Borgwardt Dec 12 '09 at 12:54
    
The page you've liked to describes issues with finding the files, which I can only assume happens after activating the checkbox. But maybe the files can be installed manually; I'll have to look into that. –  Michael Borgwardt Dec 12 '09 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.