Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Flash videos do not work properly on my Mac. On this Vimeo video, for example, it shows only the beginning frame, and audio stutters like crazy, playing audio for a quarter second or so, then silence, then playing again, etc.

I have Flash version 10,0,42,34 on Mac OS 10.5.8. It's a PowerBook G4 (PPC). I tried it in Firefox 3.5.5 and Safari 4.0.3.

I tried reinstalling Flash, restarting the computer, and using a fresh user profile in Firefox (so that no extensions are interfering with the site), loading the video fully before playing, but nothing helps.

I noticed that youtube videos work better, once loaded enough, although the picture does halt briefly once every 10 or so seconds, even when it's fully loaded.

share|improve this question
add comment

3 Answers 3

Flash performance is terrible on PPC with version 10. I don't have very good performance on a G5, and a G4 is rather old to be expecting any sort of decent performance on Flash. There are three options:

  1. Adobe has to make improvements in Flash's performance. This one isn't going to happen.
  2. You can buy an Intel Mac.
  3. You can downgrade to Flash 9. You lose some security updates as Adobe is no longer updating version 9, but version 9 does perform better on PPC. I don't recommend this option.
share|improve this answer
1  
+1 for point #1 :) –  Lawrence Velázquez Dec 13 '09 at 22:25
1  
My 933Mhz G4 sucks at most Flash video. I use ClickToFlash (rentzsch.github.com/clicktoflash) to block most Flash and occasionally download/play H.264 from YouTube. –  Chris Johnsen Jan 12 '10 at 7:57
add comment

Are you using Firefox by any chance? The picture halting briefly every ten seconds reminds me of a known issue with Firefox saving its session information.

share|improve this answer
add comment

One other partial fix:

Right-click a video while it is playing and choose the 'settings' menu for Adobe Flash player. From there, uncheck "Use Hardware Acceleration" on the Display tab, and bump the "Local Storage" tab slider bar up to 10MB.

(Found here and it improved things for me, a little.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.