Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im running ubuntu. I just tried to play supertux but my LCD didnt support the resolution and all i got was a blank screen and music playing. I tried to close it and go back to the desktop by pressing ctrl + z but that didnt work so i had to hard reset my computer!

In future what should i press when this happens?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

ctrl+alt+backspace will kill your X session and restart is, dumping you at the login window.

share|improve this answer
    
any idea where i find the supertux config files so i can change screen res? –  tm1rbrt Dec 13 '09 at 15:59
1  
Sorry, I have no clue! Have you tried looking at the man page and seeing if there are any hints? –  MDMarra Dec 13 '09 at 16:04
    
started it with -w worked ok :) –  tm1rbrt Dec 13 '09 at 16:09
    
recent versions of ubuntu (Karmic for sure, i think Jaunty too) have been nixing this option in the default configuration. google for DontZap, or check these instructions for Jaunty: maketecheasier.com/restore-ctrl-alt-backspace-in-ubuntu-jaunty/… –  quack quixote Dec 13 '09 at 16:18
    
Hm, that's pretty unnecessary. I haven't had an X session open on Ubuntu in forever, so I didn't know that. Thanks for the info –  MDMarra Dec 13 '09 at 16:27

Switch to a Virtual Terminal (Ctrl+Alt+F4), log in with your password and type "killall programname", after typing the first few letters of the program name, press tab and it should autocomplete. (e.g. killall supertux) When done Ctrl+Alt+F7 returns you to your desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.