Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I keep getting a "path is too deep" error when copying files and folders from my PC to a NAS device over the wireless network.

Anybody else had this?

When I try from Windows command prompt, I get "semaphore has expired"

Also, I tried copying a couple files from c:\ to l:\, first I got "network name no longer valid", then I got "the path is too deep" again!

The device is a Buffalo Link Station LS 500GL 500GB.

share|improve this question
what NAS device? – quack quixote Dec 13 '09 at 18:48
buffalo link station 500GB – Nick Dec 13 '09 at 19:47
model # and firmware version? have you tried updating the firmware? – quack quixote Dec 13 '09 at 20:23
LS 500GL, but I don't see that on the buffalo site! Tempted to update to the firmware of the nearest model, but that would be fighting my instincts – Nick Dec 16 '09 at 14:46
go here: ... the LS-500GL is listed in the "By Product Model" drop-down. the order is a little confusing but it's there (watch out for lookalikes, eg LS-L500GL, LS-CH500L, etc). looks like v1.15 is latest firmware? – quack quixote Dec 17 '09 at 18:55

What is the file system on the device? Windows has trouble with FAT12 and FAT16 volumes that contain path names longer than 260 bytes. Consider changing the file system over to NTFS perhaps? This limit is bumped up to 32767 characters (unicode).

On FAT12 and FAT16:

  • Entire path is limited to 260 bytes
  • File & Directory names are limited to 255 characters each


  • Entire path is limited to 32767 unicode characters
  • File & Directory names are limited to 255 characters each

The semaphore has expired error can also be related to path names that are too long.

share|improve this answer
Yeah I remember programming something in a coffee induced haze once where I surpassed the entire 260 byte limit in the depth of the directory path. CVS didn't like it. – leeand00 Dec 13 '09 at 19:29
NAS devices usually export filesystems via SMB shares, not block devices via iSCSI. so "change it to NTFS" doesn't really help here. they typically run an embedded linux, so on the device the fs is probably ext3 (maybe even ext2), and the network shares are probably supplied via Samba. – quack quixote Dec 13 '09 at 20:17
(at least, this is generally true of consumer NAS devices like the Buffalo Linkstation: ) – quack quixote Dec 13 '09 at 20:19

It really depends on the file system of your PC and NAS. If it's a Windows-related error this MSDN Article may enlightening:

In my experience, I have worked around these types of errors by shoretening the path names. Here's an over-simplified example, if I am unable to access a file named MyFile.txt:

orginal: c:\MyFolder\ReallyLongFolderName\AnotherReallyLongFolderName\MyFile.txt

changing this to: c:\Myfolder\ShortName\AnotherShortName\MyFile.txt

would allow me to access my file.

share|improve this answer

This error simply means that the full directory / file name is to long.

This is quite a common problem I have seen with people who neatly label and organise files. If for example, you have a long file path of:


and you have a backup path of


Or something similar, you get through the limit pretty fast.

On typical FAT (I think also NTFS) systems, I think the limit is 255 bytes, but not 100% sure on the exact length.

share|improve this answer
yep, one of the 'drawbacks' when using Sandboxie: it creates its shadow directories in a folder \Sandbox\User\Defaultbox\ followed by the original path. it's OK when using a RAM disk as container, on the hard drive when the path is too long, however, you'll have to resort to the usual tricks (shortening the path manually) to delete the folder. – Molly7244 Dec 13 '09 at 22:11

If the NAS isn't on a Windows computer and so doesn't suffer from the Windows path-length limitations, you might avoid the problem by using the good old subst command under cmd, like this :

subst x: nasdisk:\very\long\path
copy mydir x:

share|improve this answer

You must log in to answer this question.

protected by slhck Mar 18 '12 at 19:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .