Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The signal strength meter on my Windows 7 laptop keeps changing from two to four bars of strength and back again. It's starting to look like a peak meter from a 1980's stereo. The machine isn't being moved and it's plugged in for power.

If we assume that the meter is accurate (that the machine is seeing a 50% loss in power then getting it back repeatedly) then why is it happening?

Is there some sort of power saving feature turning down the signal on the laptop or should I start shopping for a new router?

share|improve this question
    
You might try grabbing NetStumbler (it's free) and checking to see if your signal is actually dipping up and down like that. It would give you a place to start, at least. –  Nathaniel Dec 15 '09 at 0:22
add comment

4 Answers

There's a whole bunch of environmental factors that could be influencing this. Your dog moving around in your house, for example, or the electrical supply to your boiler fluctuating, or a butterfly flapping its wings a few thousand miles away, etc etc.

Unless you're actually having problems as a result of this (e.g. you should be in range of the router but you're only getting an intermittent signal), I'd just get used to ignoring the exact meter on your desktop.

share|improve this answer
add comment

I would make sure you have installed the correct Windows 7 driver, as there have been lists of problems about wifi, which are solved by installing the correct driver

share|improve this answer
add comment

Another possible source of problem is some other wireless device either near the router or the laptop interfering with the signal. I used to have a wireless phone sitting near my router and it took me weeks to figure out that it was interfering with the router's signals.

share|improve this answer
add comment

You can update the device driver and work around with wifi hardware options in device manager, maybe disable power saving, enable aggressive roaming and also you can change the default channel id both on your laptop and the wireless router, keep it away from interfering devices and big metal surfaces and objects as they emit the signal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.