Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This quesion is a follow-up to a two-part question I previously had. It's in regards to my On Screen Display settings on my Lenovo T61.

I recently reformatted my Lenovo T61 and put Windows 7 Professional on it. I backed up the original Vista driver installers that were at C:\SWTOOLS\ so even though I didn't use them for Windows 7, I have them just in case. I had quite a bit of trouble getting my On Screen Display to show me my volume adjustments. I read a forum post at Lenovo and basically discovered there are several programs that need to be executed to turn the OSD on. They are:

  • c:\drivers\win\hotkey\osd\lvosdsvc.exe
  • c:\drivers\win\hotkey\osd\tponscr.exe
  • c:\drivers\win\hotkey\osd\tposdsvc.exe

So I added shortcuts to these three exe's into my startup folder and my up/down volume issue was fixed. But then I realized the mute OSD and the mute button itself doesn't work. So I'm wondering how I can get the mute button to work. I believe I've download the correct OSD driver from Lenovo so I'm a bit stumped on the mute button -- it worked in Vista!

To re-iterate, I have all of the original Vista drivers that came with the machine so if there's a specific Lenovo utility I need to install, I can most likely do it. I just need to know what to install or what utility I may not be running.

share|improve this question
up vote 0 down vote accepted

You need to install the Lenovo System Interface Driver for Windows7, Vista and XP - Notebooks,

I have a T61P with the same video card and was experiencing the exact same symptoms. The System Interface Driver fixed everything.

share|improve this answer
    
YES! That did it! Thanks so much for letting me know Scott – Mark Feb 5 '10 at 2:42
    
Worth note that this is a great solution for any lenovo notebook experiencing this issue, but that link is long-since gone to linkrot. – PowerLuser May 25 at 16:38

Same for me. No onscreen and mute, etc. were not working. I took an extra step to check it. Did what was suggested at Lenovo System Interface Driver for Windows7, Vista and XP - Notebooks. That did nothing.

Then I found Hotkey Features Integration for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP (32-bit, 64-bit) and 2000 - ThinkPad and after a restart it's cherry.

share|improve this answer

I just fixed a similar issue on my x300 running a clean install of Windows 7 x64. Posting my fix here in case it helps you also.

  • Right click on desktop background, select display resolution
  • Choose "Advanced Settings"
  • Click on "On Screen Display" tab

On mine, the check-box to show the OSD was unchecked, and no font size/color/etc was selected. I checked the box and filled those in, and suddenly my mute button started working. Weird but effective.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .