Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have a dual-boot setup with Windows Vista and Fedora Linux. The time between the two installations have a 6 hour gap. When I try to set the time of one OS to match the other one, the other OS adjusts its time as well so they never sync. How can I sync their times?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

I presume you live in a time zone with a 6-hour offset from UTC (GMT), such as Central Standard Time in the USA is GMT-6. Perhaps you live in Sri Lanka, where the offset is 6 hours the other side of GMT, and the time zone is GMT+6.

Both operating systems need to agree whether the system clock is set to local time or UTC.

This is probably most easily accomplished by telling Fedora to use local time. Windows is generally much harder convince to use UTC.

As suggested on a fedoraforum.org thread, at a Fedora root shell, try:

hwclock --localtime

This should tell Fedora to use treat the system clock as containing the local time, the same as Windows does by default. The operating systems should now agree on the time.

share|improve this answer

Tell the linux side not to expect that the system clock is using UTC. In Ubuntu (9.10), this is set in /etc/default/rcS. In RHEL (5u4), this is set in /etc/sysconfig/clock.

share|improve this answer
1  
Ubuntu will ask during installation; I'm not sure Fedora does. –  Broam Dec 15 '09 at 14:35
1  
Fedora also asks during installation. –  retracile Dec 15 '09 at 14:53
    
How exactly to I do that? –  Randell Dec 15 '09 at 16:43
1  
Open the file in question, change the line that says UTC=true to UTC=false, then reboot. –  Suppressingfire Dec 15 '09 at 22:55

Yes you should run NTP but not for the reasons stated herein, that will only fix the symptom not the cause. On Linux (as root) run this: hwclock --localtime --systohc

No need to regedit under Windows, no need to reboot.

share|improve this answer
    
Can you more fully explain your reasoning behind "that will only fix the symptom not the cause"? –  MaQleod Oct 3 '12 at 18:47

Check the timezone settings in both installs are the same. It sounds like setting the time on one OS is setting the computer time and the other OS is picking up the computer time but 6 hours adrift.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.